Frage von KaiserWilhelmXL, 101

Ich brauche bei einer großen Excel Liste Hilfe. Nur für Profis. Weitere Erklärung unten. HILFE?

Es ist wirklich schwer, es genau zu beschreiben. Kann man hier eine Excel-Datei hochladen?

Es ist immer mehrere "Blöcke". Also ein Block mit z.B. BMW in denen verschiedene Städte verzeichnet sind. Aber die "Blöcke" können unterschiedlich lang sein. Also Man gibt es vier mal hintereinander eine Automarke und mal zwei oder so.

Jetzt die Aufgabe: Ich muss jeden Block absuchen (und das sind tausende) ob eine Automarke in Berlin ist. Das heißt cool wäre es, wenn ein Block markiert wird, wenn Berlin NICHT vorhanden ist (Beispiel oben Ferrari). Aber dann sollte der ganze Block kenntlich gemacht werden, wenn Berlin in diesem Block nicht vorhanden ist. Versteht Ihr wie ich das meine? Und vorallem ist das überhaupt Möglich? DANKE

Antwort
von Jewi14, 89

Ist natürlich so schwer nachvollziehbar, was du genau möchtest. Sofern ich verstanden habe, hast du diverse Spalten und willst z. B. sortieren, ob Automarke A in der Stadt B ist.

Dafür gibt es das Instrument "Pivot-Tabelle" was recht einfach sowas erledigt. Hier nur mal ein kleines Video, um zu sehen, ob du sowas meinst. Ansonsten Pivot Tabellen via Google suchen

Kommentar von KaiserWilhelmXL ,

Danke. Ich kenne Pivot. Leider ist es auch grund der Menge auch nicht wirklich sinnvoll.

Kommentar von Jewi14 ,

Schade, es ist ein gutes Werkzeug für den Zweck. Nur wenn du so große Datenmengen hast, muss ich doch ein wenig kritisch hinterfragen: Warum wurde die Daten nicht in Access angelegt? 

Kommentar von KaiserWilhelmXL ,

Weiß ich leider auch nicht

Antwort
von meSembi, 101

Wie wäre es mit "bedingte Formatierung"?

Du kannst da z.B.: Alles außer Berlin in einer Farbe darstellen lasse. Jedoch wird es dann schwer, denn wenn ich deine Tabelle richtig in Erinnerung habe, standen neben Berlin auch noch andere Städte. Diese werden dann halt auch in Farbe dargestellt.

Wenn du das hast, kannst du eventuell mittels Formel (weiß gerade nicht welche) oder wiederum bedingter Fromatierung die Makre formatieren

Antwort
von Bambina555, 81

So wie das klingt brauchst du den SVERWEIS

Da markierst du eine Matrix also die Blöcke und prüfst ob etwas vorhanden ist oder nicht. Ob man die Felder dann markieren kann, kann ich dir nicht sagen aber dir wird das Feld in dem es sich befindet ausgegeben.

Kommentar von KaiserWilhelmXL ,

Wie würde dann der SVerweis aussehen und welche Ergebnis würde ich bekommen?

Kommentar von Bambina555 ,

=SVERWEIS("Berlin";B4:E27;Spaltenindex;FALSCH)

am 2. Punkt kommt die Matrix da habe ich jetzt einen beliebigen Bereich genommen. Spaltenindex ist die Spalte die ausgegeben werden soll in der Zelle und falsch für eine genaue Übereinstimmung des Wortes Berlin für das Ergebnis

Kommentar von KaiserWilhelmXL ,

Funktioniert bei mir nicht. Zeigt mir immer ein Fehler an.

Kommentar von KaiserWilhelmXL ,

Kann ich hier kein Screenshot: oder sowas hinzufügen???


Expertenantwort
von Ninombre, Community-Experte für Excel, 56

Wenn nur um eine Stadt geht, würde sich die bedingte Formatierung anbieten, also Formel zur Ermittlung der Formatierung und dort rein:

=ZÄHLENWENNS($A$1:$A$100;$A1;$E$1:$E$100;"Berlin")=0
Die $ müssen so gesetzt sein, damit es richtig markiert wird, also alle Spalten- und Zeilenbezüge fix außer der A1, da nur die Spalte

Was auf die Art nicht mehr geht, ist wenn verschiedene Städte markiert werden sollen, es kann nur eine Bedingte Formatierung auf einmal greifen.

Kommentar von KaiserWilhelmXL ,

Danke für deine Bemühungen. Ich möchte gerne, dass dann von diesem "Block" z. B. BMW markiert sind oder dann hinter allen WAHR steht, wenn bei einem Berlin steht.

Kommentar von Ninombre ,

Das mit WAHR geht so: =ZÄHLENWENNS($A$1:$A$100;$A1;$E$1:$E$100;"Berlin")>0

Kommentar von KaiserWilhelmXL ,

Unfassbar!! Du hast es geschaft!! DAAANNKKKEEE

Kommentar von KaiserWilhelmXL ,

Leider war ich zu voreilig. Eigentlich klappt es auch, aber bei einigien Automarken zeigt er WAHR an, obwohl kein Berlin enthalten ist.

Kommentar von Ninombre ,

Ist die Liste konsequent nach Automarke sortiert? Wenn irgendwo BMW und Berlin auftaucht wird jeder Eintrag von BMW in der Liste mit WAHR gekennzeichnet. Es wird auf die Kombination Marke und Ort abgefragt, nicht ob die Zeilen alle hintereinander stehen.

Kommentar von KaiserWilhelmXL ,

Ja, die Liste ist nach Automarke sortiert. Ohne Ausnahmen. Schade, ich dachte echt, du hast es geschafft

Kommentar von Ninombre ,

Ohne die Datei zu kennen ist es leider schwer zu debuggen. Stimmen die Bereiche A1:A100 hatte ich ja einfach als Beispiel verwendet bzw. E1:E100.

Gibt es andere Schreibweisen für die Marken oder Orte?

Die Formel liefert ja nicht willkürliche Berechnungen, sondern prüft zwei Bedingungen. Alternativ ginge das noch
=SUMMENPRODUKT((A$1:A$100=A1)*(E$1:E$100="Berlin"))>0

Kommentar von KaiserWilhelmXL ,

Du hast aufjedenfall Recht. Es ist wirklich schwierig aus der Ferne. Umso mehr dankbar bin ich dir, wenn du dich trotzdem bemühst. Leider ist auch der Formel das gleiche Problem. Grundsätzlich funktioniert es gut, aber dann sind jedoch unerklärbare Fehler, also wo der WAHR sagt, ob Berlin nicht vorhanden ist. Mir ist es absolut unklar.

Kommentar von KaiserWilhelmXL ,

Gibt es noch eine andere Alternative?

Kommentar von KaiserWilhelmXL ,

Geht die Variante auch mit Nummern? Also deine Formel, nur einer Zahl statt zum Beispiel BMW? Weil zu jedem Auto gibt es eine bestimmte Zahl. Ginge das?

Kommentar von KaiserWilhelmXL ,

Bei Fehler liegt bei BMW, es gibt noch ein anderen EIntrag mit BMW und da ist Berlin vorhanden. Also müsste ich mit der dazugehörigen Nummer suchen

Kommentar von Ninombre ,

Du kannst "Berlin" auch durch Zahlen ersetzen, dann braucht es die Anführungszeichen nicht

Kommentar von KaiserWilhelmXL ,

Danke, jetzt hab ich es.

Kommentar von KaiserWilhelmXL ,

Jetzt würde ich gerne zwei Städte gleichzeitig suchen, Geht das?

z.B.

"=SUMMENPRODUKT((A$1:A$100=A1)*(E$1:E$100="Berlin" ODER "München"))>0"???

Also es soll WAHR werden, wenn eins der beiden Städte vorkommt oder beide.

Kommentar von Ninombre ,

es gibt sicherlich noch einen besseren Ansatz um eine Oder-Bedingung direkt unterzubringen, auf die Schnelle aber so:

=SUMMENPRODUKT((A$1:A$100=A1)*(E$1:E$100="Berlin"))+SUMMENPRODUKT((A$1:A$100=A1)*(E$1:E$100="München"))>0
Kommentar von KaiserWilhelmXL ,

Danke

Kommentar von KaiserWilhelmXL ,

Ich hab jetzt so ein ähnliches neuen Fall, darf ich dich nochmal was fragen?

Antwort
von Herb3472, 78

Das klingt eigentlich nach einer typischen Datenbankanwendung. Warum machst Du das nicht mit MS Access und VBA?

Kommentar von KaiserWilhelmXL ,

Weil ich Dateien in CSV habe und mit Access bzw. VBA keine Ahnung von habe.

Antwort
von NoctisAlive, 77

Mach am besten nen Screenshot und zeig uns den. Mit dem Kram da oben kann ich nicht so viel anfangen, sry.

-Noctis

Kommentar von KaiserWilhelmXL ,

Danke, bin dabei ...

Keine passende Antwort gefunden?

Fragen Sie die Community