Ich benötige bitte dringend eine Kleine Excel Formel, kann mir bitte jemand helfen?

... komplette Frage anzeigen

4 Antworten

Probier mal

=WENN(UND(A1<>0;A1=B1);1;"")

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von Oubyi
23.01.2016, 16:50

DH!

Stimmt so ist es kompakter und hat den gleichen Effekt, wie meine Formel.

0
Kommentar von Marceloblau01
23.01.2016, 17:13

Danke , perfekt!!!

1

Versuch mal

=WENN(A1=B1;1;WENN(A1="";"";WENN(A1=0;"";"")))
Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von DeeDee07
23.01.2016, 16:44

Wenn A1 und B1 0 oder leer sind, wird das Ergebnis 1 sein (1. Bedingung).

Die letzte Abfrage ist in der Form überflüssig, da sowohl bei erfüllter als auch nicht erfüllter Bedingung das gleiche Ergebnis "" geliefert wird.

0

=WENN(UND(A1<>0;B1<>0);WENN(A1=B1;1;"");"")

Klappt es?

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von Oubyi
23.01.2016, 16:51

Da habe ich mal wieder zu kompliziert gedacht.
Nimm DeeDees Formel, die ist schöner!

0

ganz kurz:

=(A1<>"")*(B1<>"")*(A1=B1)

Wenn auch ein Eintrag 0 nicht zählen soll, dann reicht

=(A1<>0)*(A1=B1)


Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von Iamiam
23.01.2016, 18:06

zum Lernen auch noch eine andere Möglichkeit:

=(1-istleer(A1))*(A1=B1)

1-Logikwert kehrt diesen um

Entspricht also

=Nicht(istleer))*(A1=B1)

2