Frage von tobistar3, 31

Hyper V windows gast bekommt kein internet?

Hallo zusammen

ich habe einen virtuellen switch erstellt (extern) und auch auf dem host die IP eingetragen für den gast. Wenn ich dann einen linux gast erstelle und ihm die IP gebe dann geht das aber wieseo bekommt der windows gast nur "netzwerk" aber kein internetzugriff.

es ist egal ob ich ihm den gateway, die IP und den dns gebe oder nicht... über DHCP heißt es kein internet und sonst nicht mal netzwerk

Expertenantwort
von deruser1973, Community-Experte für Server, 16

Du musst statt dem Switch einen NAT Router erstellen. Denn vom Provider bekommst du nur genau eine IP...

Und die brauchst du selber für deinen Host. 

Kommentar von tobistar3 ,

danke erstmal für die antwort

ich habe 3 IP addressen also eine für host und rest für gäste

und das mit dem NAT Router probier ich gleich mal

Kommentar von ToxicWaste ,

Entschuldigung, aber das ist doch Quatsch.Die externe Provider-IP kommt doch erst hinter dem (DSL-)Router zum tragen.

Der virtuelle Switch in Hyper-V muss auf extern stehen, dann kann sich die VM in sein Netzwerk integrieren und eine IP vom DHCP des Routers beziehen.

Kommentar von deruser1973 ,

Ja,  wenn ein Router vorhanden ist,  dann stimmt das - zu Hause also...

Aber es gibt auch Server in Rechenzentren... und da gibt es kein DHCP für die Ip... da gibt es wirklich nur die eine...

Kommentar von ToxicWaste ,

Du willst nicht ernsthaft behaupten, dass ein Hyper-V Host in einem RZ ohne Router, ohne Firewall, ohne NAT direkt im Internet hängt?
Das dort für Server kein DHCP verwendet wird, ist allerdings richtig.
Bei der Fragestellung glaube ich aber nicht, dass der Frager in einem RZ arbeitet.

Kommentar von deruser1973 ,

Doch,  das behaupte ich... ich hatte nämlich selber schonmal einen großen Root...

Ich weiss es also... es gibt  keinen DHCP,  oder sonstige Router ...

Und eine Firewall gibt es nur Softwareseitig - also kein extra Gerät...

Wer seine Firewall nicht konfiguriert,  der hängt komplett offen im Netz - das ist ja grad bei Linux Servern das Problem, denn dort ist auch standardmässig keine Firewall konfiguriert...

Keine passende Antwort gefunden?

Fragen Sie die Community