Hilfestellung bei Excel Formel (Wenn/Istzahl/Suchen/Ersetzen)?

... komplette Frage anzeigen

3 Antworten

Das einfachste ist WECHSELN:

=WECHSELN(WECHSELN(WECHSELN(WECHSELN(WECHSELN(WECHSELN(WECHSELN(A1;"ü";"ue");"ö";"oe");"ä";"ae");"Ü";"Ue");"Ö";"Oe");"Ä";"Ae");"ß";"ss")

Es würde aber auch alles in einer Formel gehen, du brauchst nur in der Wechseln-Formel an Stelle von A1 dein Verketten (ohne Klein) einfügen, und vor Wechseln ein Klein( ergänzen, und am Ende natürlich ein ).

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von Iamiam
29.08.2016, 18:40

was spricht denn gegen Wechseln? die ist dazu da! (und unterscheidet Groß/klein)

=Klein(WECHSELN(WECHSELN(WECHSELN(WECHSELN(WECHSELN(WECHSELN(WECHSELN(A1&B1&C1&D1&"@beispiel.de";"ü";"ue");"ö";"oe");"ä";"ae");"Ü";"Ue");"Ö";"Oe");"Ä";"Ae");"ß";"ss"))

Wechseln ohne letztes Argument ersetzt ALLE genannten im Text

0

OK, ich hätte eventuell ausführlicher werden müssen. Ich kann die Funktion Wechseln nicht verwenden. In Excel probiere ich zur Zeit, ob die Formel funktioniert, aber verwendet wird sie später in MS SharePoint 2010 in einer berechneten Spalte und diese gibt mir beim Verwenden der Funktion Wechseln einen Syntaxerror. Daher bat ich darum, mir keine Vorschläge mit Wechseln zu geben.

Soooo lange Rede kurzer Sinn = hat wer eine Idee wie ich die Formel ändern könnte?  :)

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von DerAndereEine
30.08.2016, 08:55

Dann könntest du dir dafür ein Makro schreiben.

Function UmlauteErsetzen(sText As String)
  UmlauteErsetzen = sText
  UmlauteErsetzen = Replace(UmlauteErsetzen, "Ä", "Ae")
  UmlauteErsetzen = Replace(UmlauteErsetzen, "Ö", "Oe")
  UmlauteErsetzen = Replace(UmlauteErsetzen, "Ü", "Ue")
  UmlauteErsetzen = Replace(UmlauteErsetzen, "ä", "ae")
  UmlauteErsetzen = Replace(UmlauteErsetzen, "ö", "oe")
  UmlauteErsetzen = Replace(UmlauteErsetzen, "ü", "ue")
  UmlauteErsetzen = Replace(UmlauteErsetzen, "ß", "ss")
End Function

Die Formel wirkt so schon verkrampft genug. Wenn, würde ich sie auf mehrere Zeilen verteilen, um die Zeichen nacheinander auszutauschen. 

0

Verwende am besten die Formel WECHSELN.

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von DerAndereEine
29.08.2016, 15:51

Wenn du die iterative Berechnung aktivierst, kannst du es easy in einem Rutsch machen.

Datei → Optionen → Formeln → (x) Iterative Berechnung aktivieren, Maximale Iterationszahl: 10 (z. B.)

A1: Feld mit dem Text, in dem äöüÄÖÜß enthalten ist
E1: Feld, in dem die Sonderzeichen konvertiert werden sollen
F1: Iterationszähler

E1: =WECHSELN(WENN(F1<=1;KLEIN(A1);E1);WAHL(F1;"ä";"ö";"ü";"ß");WAHL(F1;"ae";"oe";"ue";"ss"))
F1: =WENN(F1=5;1;F1+1)
1

Was möchtest Du wissen?