Hilfe bei Excel Wenn Funktionen?

... komplette Frage anzeigen

3 Antworten

=WENNFEHLER(A1*1;LINKS(A1;SUCHEN("X";A1;1)-1)*TEIL(A1;SUCHEN("X";A1;1)+1;99))

Durch das x wird der Eintrag zu Text, der bei Multiplikation mit 1 einen Fehler ergibt. Der Eintrag wird dann aufgelöst in einen Teil vor dem x und einen danach. Durch die Multiplikation werden die Teiltexte wieder zu Zahlen und normal ausmultipliziert.

Suchen unterscheidet nicht zwischen Groß/klein, Finden würde unterscheiden. Also je nach Erfordernis (wenn 2X50 nicht ausmultipliziert werden sollte, dann Finden)

Hast Du vor und nach dem x Leerzeichen stehen, dann entweder -/+ 2 anstatt 1 oder -wenn unbestimmt-  A1 ersetzen durch Wechseln(A1;" ";""):

=WENNFEHLER(A1*1;LINKS(Wechseln(A1;" ";"");SUCHEN("X";Wechseln(A1;" ";"");1)-1)*TEIL(Wechseln(A1;" ";"");SUCHEN("X";Wechseln(A1;" ";"");1)+1;99))

Du kannst auch das nochmal in ein WENNFEHLER(obige Formel;"andere Struktur!") einbetten, dann bekommst Du Info, wenns nicht geht!

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von Oubyi
28.12.2015, 11:59

DH!

0

Probier mal, mit dem Namensmanager einen neuen Namen anzulegen (z. B. "eval") und dafür folgende Formel zu definieren:

=AUSWERTEN(WECHSELN(INDIREKT("ZS(-1)";FALSCH);"x";"*"))

(ungetestet)

In der Zelle rechts von der Formelspalte schreibst du einfach =Eval

Antwort bewerten Vielen Dank für Deine Bewertung

Bei der Lösung gehst Du folgendermaßen vor:
Du überprüfst zunächst ob in dem Feld eine Zahl steht, falls ja, nimm die Zahl (Eine ‚WENN‘ Funktion, die Überprüfung machst Du mit ‚ISTZAHL‘)
Ist dem nicht so, extrahiere und multipliziere die Zahlen
Zahl links: Funktion ‚LINKS‘, suche das ‚x‘ und ziehe eine Stelle für das Leerzeichen ab. Beispiel ‚40 x 30‘: x an Position 4, ziehe 1 ab (Leerzeichen) – also nimm alle Zeichen bis zur 3. Stelle von der linken Seite – sprich, 40.
Zahl rechts: Funktion ‚RECHTS‘, zähle die Anzahl der Zeichen (‚LÄNGE‘), suche ‚x‘ und ziehe das ab. Wieder eins mehr wegen Leerzeichen. Beispiel 40 x 30: 8 Zeichen insgesamt, x an Position 4, 8-4 = 4, ziehe 1 ab = 3 -> also nimm alle Zeichen bis zur dritten Stelle von der rechten Seite – sprich: 30.
Mein Excel ist auf Englisch, ich hoffe die deutschen Übersetzungen stimmen, wenn nicht, google danach. Die englische Formel stimmt.

Antwort bewerten Vielen Dank für Deine Bewertung