Frage von Jogir, 54

Hilfe bei Excel-Formel?

Diese Formel soll kreiert werden WENN in den Text von Zelle A1 ein 'a' ist

DANN soll der Preis, der in A2 steht durch die Anzahl der Zeichen in A1 geteilt und in B2 angezeigt werden

SONST soll 0 Euro als Preis reingeschrieben werden

Antwort
von PWolff, 38

Einen Buchstaben kannst du mit der Funktion FINDEN (berücksichtigt Groß-/Kleinschreibung) bzw. SUCHEN (ignoriert Groß-/Kleinschreibung) suchen lassen:

FINDEN("a";A1)

Wenn der Buchstabe im Text von A1 nicht gefunden wird, erzeugt FINDEN aber einen Fehler. Darauf kann man mit ISTFEHLER prüfen:

ISTFEHLER(FINDEN("a";A1))

Dieser Ausdruck liefert aber FALSCH (KEIN Fehler), wenn ein "a" im Text von A1 enthaltn ist, und sonst WAHR, also gerade umgekehrt, wie du es anscheinend haben möchtest. (Du kannst natürlich auch das 2. und 3. Argument von WENN tauschen). Also kehren wir den Wert um:

NICHT(ISTFEHLER(FINDEN("a";A1)))

Die Anzahl der Zeichen im Text von A1 wird bestimmt mit der Funktion

LÄNGE(A1)

Jetzt musst du diese Bausteine noch in die WENN-Funktion einbauen.

Expertenantwort
von Oubyi, Community-Experte für Excel, 27

=WENNFEHLER(A2/(FINDEN("a";A1)>0)*LÄNGE(A1);0)

Antwort
von merkurus, 40

Pobier es mal mit folgender Formel in B2

=WENN(ZÄHLENWENN(A1;"*a*")>0;A2/(LÄNGE(GLÄTTEN(A1)));0)

Keine passende Antwort gefunden?

Fragen Sie die Community

Weitere Fragen mit Antworten