Frage von KaiserWilhelmXL, 62

Hi, ich möchte in Excel wenn ich einen bestimmten Begriff eingeben, dass er sich dann zu diesem Begriff den Wert von einer anderen Tabellenmappe holt. Geht das?

Also wenn ich zum Beispiel das Wort BMW in A1 eingeben, dann soll Excel aus einer anderen Tabellenblatt (da steht dann A1 BMW A2 135) den Wert in der Zelle A2 rausziehen. Wisst Ihr was ich meine? Also wenn ich BMW eingeben, soll dann 135 daneben stehen. Und BMW ist nur ein Beispiel und es sollen mehrere Daten in dem 2. Tabellenmappe hinterlegt werden. Wenn es Möglich ist noch für verschiedene Jahre, also BMW -> 2012= 135 BMW -> 2013= 140 usw.

Ich danke euch.

Antwort
von PWolff, 35

Wenn du z. B. in Tabelle2 stehen hast  

  |    A         B
--+-----------------------------
1| BMW Mercedes
2| 15 12

dann nimmst du als Formel

=WVERWEIS(A1;Tabelle2!$A$1:$B$2;2)

(Wobei es meistens übersichtlicher ist, solche Tabellen untereinander anzuordnen, dann sieht die Formel bei z. B. 120 eingetragenen Marken so aus:

=SVERWEIS(A1;Automarken!$A$1:$B$120;2)

Du kannst auch auf andere Arbeitsmappen (Excel-Dateien) zugreifen mit

'[Name der anderen Datei.xls]Name der anderen Tabelle'!$A$1:$B$120

statt

Tabelle2!$A$1$:B$120

- die Hochkommas (') um Datei- und Tabellenname sind erforderlich

)

Kommentar von KaiserWilhelmXL ,

Wow, das sieht super aus. Ginge es das so in der Tabelle2?

  |  Automarke   2012   2013
--+-----------------------------
1| BMW 140 145
2| Mercedes 150 200
3 Porsche 160 175
 4 usw. usw. usw.

Und in der 1. Tabelle gebe ich dann manuell die Daten ein:

 | Automarke Jahr Wert
--+-----------------------------
1| BMW 2012 .....
2|
3
 4

Ich hoffe, das ist so verständlich. Vielen Dank.

Kommentar von iMPerFekTioN ,

Wenn du die Jahreszahlen miteinbeziehen willst, kannst du das in eine WENN-Funktion verpacken, da kannst du z.B. eine Dropdownliste erstellen und diese in A2 einfügen.

Die Liste enthält dann z.B. die Jahreszahlen 2012 und 2013
Dann könntest du diese Formel verwenden:

=WENN($A$2="2012";SVERWEIS($A$1;Tabelle2!A2:B300;2;0);WENN($A$2="2013";SVERWEIS($A$1;Tabelle2!A2:B300;3;0);"")

Dann wird je nach Auswahl deiner DropDown Liste auch die Zahl zum angegebenen Jahr ausgegeben.

Grüße,

iMPerFekTioN

Kommentar von PWolff ,

Stimmt, das 4. Argument hab ich vergessen - wenn hier nicht 0 steht, muss man die Marken alphabetisch geordnet haben. Danke für die Korrektur!

-----

Ich schreib die Tabellen hier noch mal hin, damit ich die Übersicht besser halten kann:

Tabelle "MarkenJahreWerte":

 | A B C
--+-----------------------------
1| Automarke 2012 2013
1| BMW 140 145
2| Mercedes 150 200
3| Porsche 160 175
 4| usw. usw. usw.

Tabelle "Tabelle1"

 | A B C
--+-----------------------------
1| Marke Jahr Wert
2| BMW 2012 ....
3|
4|
 5|

Man kann auch den Spaltenindex (3. Argument) berechnen lassen - mit der Funktion VERGLEICH:

VERGLEICH(B2;MarkenJahreWerte!$B$2:$B$65536)

(hier kann man die 0 als 3. Argument weglassen, solange die Jahre von links nach rechts aufsteigend sortiert sind)

Damit sähe die ganze Formel dann so aus (im Beispiel für C2):

=SVERWEIS($A2;MarkenJahreWerte!$A$1:$IV$65536;VERGLEICH(B2;MarkenJahreWerte!$B$2:$B$65536)+1;0)

Kommentar von KaiserWilhelmXL ,

Bei der Formel "=SVERWEIS($A2;MarkenJahreWerte!$A$1:$IV$65536;VERGLEICH(B2;MarkenJahreWerte!$B$2:$B$65536)+1;0)" bekomme ich immer ein Wert 0.

Kommentar von KaiserWilhelmXL ,

Wow, das sieht wirklich Perfekt aus.Ich nur noch kleine Probleme die Formel an meine Excel Liste anzupassen.

So sieht mein Excel aus:

Tabelle1:

 | A B C
--+-----------------------------
1| Automarke Jahr Wert
2| BMW 2012 ?
3
 4

Tabelle2:

 | A B C
--+-----------------------------
1| Automarke 2012 2013
2 BMW 100 150
3| Mercedes 200 250
4 Porsche 300 350
 
Kommentar von KaiserWilhelmXL ,
...
Kommentar von PWolff ,

Sorry, Denkfehler. Korrektur

=SVERWEIS($A2;Tabelle2!$A$1:$IV$65536;VERGLEICH(B2;Tabelle2!$B$1:$IV$1;0)+1;0)

Kommentar von KaiserWilhelmXL ,

Mhh. jetzt bekomm ich ein Fehler oder das Jahr 2012 raus.

So hab ich Formel drin:
=SVERWEIS($A2;Tabelle1!$A$1:$IV$65536;VERGLEICH(B2;MarkenJahreWerte!$B$1:$IV$1;0)+1;0)

Kommentar von iMPerFekTioN ,

@KaiserWilhelmXL:
Was gibst du genau in deine Suchzelle ein?

Kommentar von KaiserWilhelmXL ,

Ah jetzt habe ich es. VIELEN DANK AN ALLE

Kommentar von PWolff ,

Tausch in der Formel die Tabellennamen "Tabelle1" und "MarkenJahreWerte" gegen "Tabelle2" aus.

Kommentar von KaiserWilhelmXL ,

Genau. Vielen Dank.

Antwort
von iMPerFekTioN, 28

Hallo,

wie bereits gesagt wäre es besser wenn du die Tabelle Hierarchisch neben einander anordnest.

Sprich,

Tabelle2:
A1=Markenbezeichnung
B1=Zahlen

So, jetzt hast du in derTabelle1 sagen wir mal in der Zelle A1 ein Eingabefeld.

Da gibst du die Automarke ein (z.B. BMW)

In die Zelle B1 in der Tabelle1 gibst du folgende Formel ein:

=SVERWEIS($A$1;Tabelle2!A2:B200;2;0)

So bekommst du immer die Zahl die hinter der Marke steht.

Grüße,

iMPerFekTioN

Expertenantwort
von Ninombre, Community-Experte für Excel, 62

=sverweis(a1;Tabelle2!A:B;2;falsch)

Kommentar von KaiserWilhelmXL ,

Genau, sowas suche ich. Kann den SVerweis noch mit dem jeweiligen Jahr ergänzen? Danke.

Kommentar von Ninombre ,

das geht dann als Kreuztabelle mit Index und Vergleich

=INDEX($B$2:$C$3;VERGLEICH("BMW";$A$2:$A$3;0);VERGLEICH(2012;$B$1:$C$1;0))

In meinem Beispiel ist es nur eine Minitabelle mit 4 Feldern, das kannst Du aber nach Bedarf einfach erweitern

B2:C3 sind die Ergebnisfelder
A2:A3 die Automarken
B1:C1 die Jahre

Kommentar von Dano9889 ,

Er hat die Zahlen ja in A2 und nicht in Spalte B ;)

Kommentar von iMPerFekTioN ,

Ja und?=) Es war schon richtig kommuniziert, Ninombre hat auch recht mit der Formel, ist auch besser auf den Weg.

KaiserWilhelmXL hat das scheinbar auch verstanden sonst würde er nicht sagen das es Funktioniert.

Keine passende Antwort gefunden?

Fragen Sie die Community