Hat jemand eine Excel Formel für eine Personenvertretung?

... komplette Frage anzeigen

1 Antwort

Eigentlich wollte ich schon schreiben, dass das mit Formeln nix wird. Dann hab ich es allerdings als Herausforderung gesehen.

Trotzdem ist es nicht die eine Formel, daher ein Beispielsheet
http://workupload.com/file/4YZGRAwv

Wenn es nicht die 8 Mitarbeiter sind, dann solltest Du die Formeln näher anschauen, um es erweitern zu können. Wenn es unklar ist bitte fragen. 

Es gibt zwei Tabellen:

1. Übersicht der Nummern je Mitarbeiter

2. Die Verteillogik: Zunächst Ermittlung wie viele Nummern wg. Ausfall verteilt werden müssen (zwar standardmäßig 10 je Mitarbeiter, kann aber auch geändert werden) und wer gem. Arbeitsanteil wie viele übernehmen muss. Ich hab aus der Frage entnommen, dass jede Zahl aus 10 Unterpunkten besteht. 10 Nummern entsprechen also 100 Unterpunkte, die zu verteilen sind.

Danach wird die Liste der Nummern des Kranken auf die verbleibenden verteilt. Hinsichtlich Vergabe werden die 100 Nummern je Mitarbeiter einfach der Reihe nach gem. Arbeitsanteil an die verbleibenden Mitarbeiter verteilt. Da eine Logik reinzubauen, dass noch schöne Päckchen geschnürt werden, übersteigt dann meine Fähigkeiten mit Formeln

Es funktioniert auch nur, wenn nur 1 MA krank ist. Wenn mehr als einer ausfallen soll, muss eine andere Logik her. (Als Workaround: Die Nummern des zweiten kranken Mitarbeiters temporär an die Liste des ersten kranken anhängen)

Bei bestimmten Zahlenverhältnissen kommt der letzte Mitarbeiter besser davon als die Kollegen, das ist meinem Verständnis nach aber beim Runden nicht zu vermeiden.

Zumindest die eine Formel sollte man erklären:

=WENN(UND(C$5="";ZEILE(B16)-15<=C$7);INDEX('Nummer je MA'!$A:$H;ZEILE(A16)-14+SUMMENPRODUKT(($B$7:B$7)*($B$4:B$5=""));VERGLEICH("x";$B$5:$I$5;0));"")

Ich geh über die Zeilenzahl, um die Nummern aufzulisten, die der Mitarbeiter in Vertretung übernehmen muss. Da die Liste in Zeile 16 beginnt, müssen 15 abgezogen werden, um den ersten Eintrag darzustellen.

Bedingung dafür, dass ein Eintrag erzeugt wird, ist also, dass der Mitarbeiter nicht abwesen ist (C5="") und die laufende Zeile kleiner ist als die Anzahl der Nummern, die der Mitarbeiter übernehmen muss. D.h.: Wenn die Zeilenanzahl die Zahl der zu übernehmenden Nummern überschreitet wird kein weiterer Eintrag mehr erzeugt. 

Es wird dann aus dem anderen Tabellenblatt die Nummern des kranken Mitarbeiters übernommen. Das ist etwas umständlicher: Index verweist auf die Matrix in der zweiten Tabelle.
Zeile:  Laufende Zeile der Zuordnung+ die Anzahl der Einträge, die den anderen Mitarbeitern bereits zugeordnet wurden. Das wird mit dem Summenprodukt ermittelt.
Spalte: Eintrag x suchen

Antwort bewerten Vielen Dank für Deine Bewertung

Was möchtest Du wissen?