Frage von timpi35, 55

Hat ein Excel-Experte eine Lösung?

Hallo, folgendes Problem versuche ich zu lösen. Ich habe in Zelle A verschiedene Kundennummern, in Zelle I wiederum Kundennummern und in Zelle J den Umsatz der Kundennummern. Ich möchte gern den Umsatz aus J, des Kunden aus I, wenn er diesen in A findet, in G anzeigen.

Gibt es hier eine Möglichkeit? Vorab schon mal vielen Dank.

Antwort
von Rubezahl2000, 19

Um Missverständnisse zu vermeiden, erst mal ein kleiner Tipp:
Verwende bei EXCEL die Bezeichnungen Zeile, Spalte und Zelle in ihrer richtigen Bedeutung, sonst ist es für andere schwieriger zu verstehen!
Die Bezeichnung "Zelle A" gibt's nicht, du meinst vermutlich   "Spalte A"
Bei "Zellen" sind die Bezeichnungen z.B. "Zelle A1" oder "Zelle D7".
Zellen sind immer einzelne Zellen, aber nie ganze Zeilen oder Spalten.
Zeilen werden mit der entspr. Zeilennr. bezeichnet, z.B. "Zeile 3"

Jetzt zu deiner Frage:
Wenn die Kundennummern in den Spalten A und I bzgl. Schreibweise und Format wirklich zusammenpassen, dann geht's mit der sverweis-Formel.
Wenn deine Einträge in Spalte A in der 2. Zeile beginnen, dann schreib in Zelle G2 die Formel:
=SVERWEIS(A2;I:J;2;FALSCH)
Dann die Formel runterkopieren, so weit wie Werte in Spalte A vorhanden sind.
Die Formel liefert pro Zeile den zugehörigen Wert aus Spalte I.
Wenn in Spalte A eine Kundennr steht, die nicht in Spalte I enthalten ist, dann liefert die Formel "#NV"

Problematisch wird so eine Auswertung immer dann, wenn die Vergleichswerte (deine Kundennummern) eine unterschiedliche Schreibweise oder Format haben. Z.B. Textformat <-> Zahlenformat oder ein einzelnes Leerzeichen, das versehentlich eingegeben wurde am Ende einer Kundennr. sorgt schon dafür, dass die Zuordnung NICHT funktioniert, obwohl es so aussieht, als wäre die Kundennr. identisch.

Antwort
von dap123, 38

Das sollte mit der Funktion SVERWEIS funktionieren. Allerdings ist Excel keine Datenbank, insofern sind (a) die Möglichkeiten begrenzt und (b) ist es nicht immer sinnvoll, sowas damit zu machen.

Kommentar von sternstefan ,

In die Zelle G gehört:

=SVERWEIS(A1;I1:J30;2;FALSCH)

Zuerst die Zelle deren Inhalt gesucht werden soll, dann der Bereich in dem nach Übereinstimmung gesucht werden soll, die zweite Spalte soll als Ergebnis ausgegeben werden.

Damit kannst du allerdings nicht mehrere Umsätze eines Kunden aufaddieren. Die Funktion gibt dir nur den ersten Treffer.

Expertenantwort
von Ninombre, Community-Experte für Excel, 33

Das könnte (wie so viele Probleme) mit Summenprodukt lösbar sein

=SUMMENPRODUKT((J:J)*(A:A="x"))

Wobei ich die genaue Logik noch nicht verstanden habe: Sollen in der Zeile die KDNR in A und I identisch sein?

Kommentar von timpi35 ,

Hi, erstmal vielen Dank für die schnellen Antworten.

Ich möchte eine Ausweitung von Kunden machen.

In Zelle A habe ich Kundennummern erfasst. Jetzt habe ich aus eine Tabelle bekommen, wo diese Kundennummern und deren Umsatz stehen.

Ich wollte diese Daten in Zelle I (Kudennummer) und in Zelle J ( Umsatz) kopieren. Nu wollte ich das die Kundennummern aus I in A gesucht werden und sollte Die Kundennr. aus I und A identisch sein, möchte ich den Umsatz aus J der neben der Kundennummern aus I steht in Zelle G anzeigen.

Klingt kompliziert, ich weiß.

Trotzdem danke für jede Lösung.

Kommentar von Ninombre ,

dann in G:
=SUMMENPRODUKT((J:J)*(I:I=A1)) und die Formel bis zum Ende der Einträge in Spalte A kopieren.

Kommentar von timpi35 ,

Vielen Dank, funktioniert prima.

Kommentar von timpi35 ,

Hi, würde es auch funktionieren, wenn ich gleich auf die Daten Kundennummer und Umsatz aus der anderen Tabelle zugreifen

möchte? Da spare ich mir das kopieren in die aktuelle Tabelle.

Kommentar von Ninombre ,

Auf ein anderes Tabellenblatt kannst Du auch verweisen:
=SUMMENPRODUKT((Tabelle1!J:J)*(Tabelle1!I:I=A1))

Wenn Leerzeichen im Namen sind dann mit 'Tabelle 1'!

Keine passende Antwort gefunden?

Fragen Sie die Community

Weitere Fragen mit Antworten