Hallo, wie füge ich in Excel zwei Zeilen zusammen, so dass Inhalte teilweise übernommen und teilweise geöscht werden?

... komplette Frage anzeigen

2 Antworten

Ich würde das mit einem Makro lösen:

Sub Zusammenfuehren() 
 Dim i As Integer
 Dim rDatumEnde As Range
 For Each rDatumEnde In Range(Range("H2"), Range("H:H").End(xlDown)) If rDatumEnde.Value + 1 = rDatumEnde.Offset(1, 0).Value Then rDatumEnde.Value = rDatumEnde.Value + 1 rDatumEnde.Offset(1, 0).EntireRow.Delete End If Next End Sub
Antwort bewerten Vielen Dank für Deine Bewertung

Wenn es nur um Zeile 2 und 3 geht, schreibst Du in Spalte A (wo die zusammengefassten Zeilen stehen sollen)
=WENN($H2-$G3=-1;A2;"") und ziehst die Formel bis zur letzten Spalte (daher die $ vor den Spaltenbezeichnungen, damit sich die Prüfung auf das Datum nicht mitverschiebt)
außer eben in die Spalte H: Dort wäre es
=WENN($H2-$G3=-1;H3;"")
Allerdings ist die Fragestellung nicht ganz eindeutig:
1. Was passiert wenn das Datum nicht der vorherige Tag ist? In genannter Formel bleiben die Felder dann einfach leer
2. Welche Zeilen sollen denn zusammengefasst werden? In Deinem Beispiel sind das ja nicht nur 2 und 3, sondern sämtliche Einträge sind mit diesem Tag Abstand angelegt. Willst Du dann eine einzige Zeile haben?

Antwort bewerten Vielen Dank für Deine Bewertung