Hallo, Wer kann mir bei einer Datumsberechnung in Excel helfen?

... komplette Frage anzeigen

2 Antworten

Mal von A1=HEUTE() ausgehend:

A2: =WENN(WOCHENTAG(A1+5;11)=6;A1+4;WENN(WOCHENTAG(A1+5;11)=7;A1+6;WOCHENTAG(A1+5)))

und herunterziehen.

Antwort bewerten Vielen Dank für Deine Bewertung

=Startdatum+5+wenn(Rest(Startdatum+5;7)=0;-1;0)+wenn(Rest(Startdatum+5;7)=1;1;0)

Da Rest(Datum;7) unabhängig vom Gebietsschema ist, eignet es sich bester für den interkontinentalen Austausch als das meist empfohlene Wochentag().

PS: Rest(Freitagsdatum;7)=6, Rest(Samstagsdatum;7)=0, Rest(Sonntagsdatum;7)=1,

(Da die StandardDatumsrechnung in xl mit So, dem 1.1.1900 beginnt (der Sa davor, 31.Dez.1899 wäre tag 0, allerdings rechnet xl für die Tage 31.12.1899 bis 29.2.1900, den es nicht gab, ohnehin falsch.

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von Iamiam
01.02.2016, 18:28

Bei Feiertagen wirds tatsächlich schwierig:

  1. hängt es davon ab, mit welcher Art von Feiertagsliste Du arbeitest,
  2. sind die Feiertage von (sogar Bundes-)Land zu Land anders
  3. kommt es drauf an, welcher Ersatztag gewählt werden soll: Mo-Do +1 ? dann kommst du an Brückenwochenenden in die Bredouille, von Di-Fr -1? Montagsproblem (Oster-, Pfingst-, ggf weitere).

Ohnehin kann es passieren, dass Sa-1 oder So+1 auf Feiertage fallen, da muss man schon mal manuell nachkorrigieren!

0