Frage von Sahara28, 80

Hallo, geht es in Excel mehrere Werte (z.B. 1,2 und 3) in eine Zelle einzutragen und danach mit einer Formel zählen zu lassen wie oft 1 in der Spalte vorkommt?

Hilfreichste Antwort - ausgezeichnet vom Fragesteller
von augsburgchris, 57

Wenn die jeweilige Zahl nur einmal pro Zelle vorkommen kann dann so:

A1:A100: deine Texte

B2: Abfragewert

C2: {=SUMME(WENN(ISTZAHL(FINDEN(B2;A1:A100));1;0))}

Achtung Arrayformel: Geschweifte Klammer nicht mit eingeben sondern die Formel mit Strg+Umschalt+Enter abschliessen.

Expertenantwort
von DeeDee07, Community-Experte für Excel, 52

Nun, es geht zwar, die Zahlen mithilfe von Textfunktionen aus dem String zu extrahieren und dann zu addieren, aber es ist grundsätzlich eine schlechte Idee, mehrere Informationen in eine Zelle zu packen.

Viel besser für die Tabellenstruktur ist es, jede Information in eine eigene Zelle zu schreiben. Sonst kriegt man Schwierigkeiten beim Sortieren, Filtern, Verweisen und jeder Wert-bezogenen Funktion.

Expertenantwort
von Ninombre, Community-Experte für Excel, 44

Der einfachste Weg wäre über eine Hilfsspalte:
Dort =FINDEN(1;A1) bzw. die Spalte anpassen und entsprechend für die Zeilen runterkopieren.

Am Ende kannst Du dann mit =Anzahl(A1:A100) die Gesamtzahl ermitteln. Das gilt aber in dieser Form nur, wenn immer nur max. einmal die 1 pro Zelle vorkommt. "1,2,1" würde nicht richtig erfasst werden.

Antwort
von KingNewfag, 53

=ZÄHLENWENNS(A1:A3;1)

Kommentar von Sahara28 ,

Vielen Dank für die schnelle Antwort!

habe es gerade versucht aber leider hat es nicht so funktioniert wie ich es gern hätte.... Wie müssen die Zahlen denn in der Zelle formatiert sein? Und wie müssen sie angeordnet werden, also mit Komma oder Punktstich oder in Anführungszeichen, damit die beiden Zahlen getrennt und nicht als eine Kommazahl von der Formel erkannt werden?

Denn wenn ich jetzt mit Zählenwenns arbeite erkennt Excel beispielsweise die Zahl 1,2  aber nicht die beiden seperaten Zahlen 1 und 2

Viele Grüße

Keine passende Antwort gefunden?

Fragen Sie die Community

Weitere Fragen mit Antworten