Hallo! Formel anwenden in Exel,wie?

... komplette Frage anzeigen

2 Antworten

=WENN(B1="x";M18;WENN(B2="x";M19;""))
Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von Suboptimierer
20.04.2016, 13:32

Wenn du mit "auswählen" markieren meinst, könntest du das mit VBA lösen:

Sub ZellenAuswaehlen()
  If Range("B1").Value = "x" And Range("B2").Value = "x" Then
    Range("M18:M19").Select
  ElseIf Range("B1").Value = "x" Then
    Range("M18").Select
  ElseIf Range("B2").Value = "x" Then
    Range("M19").Select
  End If
End Sub
1

Ich würde es wie nachstehend machen, falls ich dich richtig verstanden habe:

1. z.B. in Zeile Z1 muss x stehen

2. in Zeile M18 steht dann =wenn(b1=$z$1;b2;0)

3. die Zeile M18 in M19 kopieren

--> wenn kein x in den Zeilen steht wird im M dann 0 ausgegeben.

Ich hoffe das hilft dir weiter.

Antwort bewerten Vielen Dank für Deine Bewertung