Hallo, brauche Excel Fachwissen ;) Thema Unterschiedliche Wochenzeiten bei Arbeitszeiterfassung. Nähere Infos in den Details. Wer kann helfen?

... komplette Frage anzeigen

3 Antworten

Du kannst die Sollarbeitszeit der Woche über die Restfunktion ermitteln:

=18+REST(KALENDERWOCHE(<ZelleMitDatum>);2)*5

Die Soll-Tagesarbeitszeit errechnet sich dann aus diesem Wert durch 5.

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von Suboptimierer
30.03.2016, 18:49

Ein Problem, das ich noch sehe ist, wenn ein Jahr eine ungerade Anzahl an Wochen hat. Dann könnte man sich behelfen, indem man 

=18+(REST(<ZelleMitDatum>;14)>6)*5

rechnet.

0

Du könntest mit der Funktion KALENDERWOCHE arbeiten und dich dabei auf ein Datum der jeweiligen Woche beziehen. Wenn z.B. in A1 der 01.04.16 als Datum steht, dann ergibt
=KALENDERWOCHE(A1) --> 14 (bzw. 13*)

Jetzt kannst du prüfen, ob die KW gerade** oder ungerade ist und entsprechend die Wochenstundensollzahl ermitteln
=WENN(REST(KALENDERWOCHE(A1);2)=1;18;23)
(ggf. Dann- und Sonst-Teil tauschen)

*Die Funktion KALENDERWOCHE kann in Excel abweichend vom Standard sein. Lies dir dazu diese Erläuterungen durch https://support.office.com/de-de/article/KALENDERWOCHE-Funktion-e5c43a03-b4ab-426c-b411-b18c13c75340 und http://www.excelformeln.de/formeln.html?welcher=7

**Man kann natürlich auch die GERADE-Funktion verwenden, REST ist allerdings universeller.

Antwort bewerten Vielen Dank für Deine Bewertung