Frage von Klosinho120184, 43

Hallo zusammen, wie kann man in Excel mehrere Werte miteinander verknüpfen und trotzdem unterschiedlich auswerten?

Wir sind ein Transportunternehmen und werden von unserem Auftraggeber nach Paketen bezahlt. Allerdings bezahlen wir unsere Unternehmer nach Stopps.

Dabei tritt folgendes Problem auf:

Wir stellen oft an Firmen mehrere Pakete zu und vergüten unserem Unternehmer nur einen Stop.

Ich habe jetzt eine Excel-Datei bei der ich gerne folgendes hätte:

Eine Verknüpfung von Datum (Feld: B2) und Tour (Feld: J2). Die Bedingung sollte wie folgt lauten:

Wenn beispielsweise am 03.12. ein Paket an Firma XY zugestellt wird, dann soll die Excel-Formel eine "1" auswerten. Wenn jedoch am selben Tag eine weitere Sendung an die selbe Firma zugestellt wird, dann soll eine "0" stehen.

Kann mir da jemand helfen?

Vielen Dank schon mal im Voraus. :)

Antwort
von Sawascwoolf, 43

Wenn die Daten nicht sortiert sind nach Datum und anschließend nach Empfänger wird das schwer.

Sollten die Daten sortierbar sein, dann geht das mit einer einfachen Wenn-Formel

=WENN(UND(B3=B2;J3=J2);0;1)
Kommentar von Jackie251 ,

das funktioniert nicht korrekt, hier erhält das letzte Paket die 1 nicht das erste

Kommentar von Sawascwoolf ,

Das kommt ja auf die Sortierung an...  Achso, die Formel gehört natürlich in Zeile 3, hatte ich vergessen zu erwähnen.

Antwort
von Jackie251, 37

das kannst du hiermit erreichen

=(ZÄHLENWENNS($B$2:B2;B2;$J$2:J2;J2)=1)*1
Kommentar von Sawascwoolf ,

Geniale Formel :D Den Bereich durch die $ oben festzuhalten und somit dynamisch zu erweitern... auf die Idee bin ich bisher noch nicht gekommen


Allerdings stimmt das so nicht ganz, es können ja auch mal 5 Pakete am gleichen Tag zum gleichen Empfänger geschickt werden.

Kommentar von Jackie251 ,

Bei 5 Paketen an einem Tag erfüllt auch nur das erste die Bedingung, da es naja eben die erste Kombination von Tag + Empfänger ist.
Und nur wenn im Zählbereich genau einmal die Kombination auftritt gibts eine 1.
Beim 2. Paket findet Zählewenns schon 2 Möglichkeiten - daher fällt der Check "=1" negativ aus und es gibt eine 0

Kommentar von Sawascwoolf ,

Ah, ich hätte die Formel in Zeile 3 geschrieben^^ - da hätte sie aber keinen Sinn ergeben^^

Kommentar von Oubyi ,

DH!
Da ich ZÄHLENWENNS nicht so mag und lieber mit Wahrheitswerten arbeite, hätte ich es so gelöst:
=(SUMMENPRODUKT(($B$2:B2=B2)*($J$2:J2=J2))=1)*1
Aber natürlich sind beide Lösungen gleichwertig.

Kommentar von Jackie251 ,

Ich mag Summenprodukt nicht, weils es eigentlich Produktsumme heißen müsste ;-D

Keine passende Antwort gefunden?

Fragen Sie die Community

Weitere Fragen mit Antworten