Frage von carlo1985, 41

hallo Zusammen, könnt Ihr mir bitte mit der Wenn Dann Schleife helfen. Die genaue Beschreibung ist im Bild (Zelle C2) beschrieben. Vielen Dank in Voraus?

Hilfreichste Antwort - ausgezeichnet vom Fragesteller
von daCypher, 17

=WENN(ISTFEHLER(FINDEN("GANG";GROSS(A2)));"AUTOMATIK";GROSS(TEIL(A2;FINDEN("GANG";GROSS(A2))-2;6))

Erklärung: Die Funktion versucht, das Wort "GANG" zu finden, wenn es nicht gefunden wird, gibt die Finden-Funktion einen Fehler zurück und es wird "AUTOMATIK" hingeschrieben. Wenn das Wort gefunden wird, wird ab 2 Zeichen vorher das Wort ausgeschnitten und hingeschrieben (kannst also auch 4-gang, 3-gang, 7-gang und so weiter hinschreiben). Nur wenn die Beschreibung mit dem Wort "Gang" anfängt, gibts nen Fehler.

Antwort
von Mneuer123, 18

Beschäftige dich mal mit der WENN-Funktion in Verbindung mit der FINDEN-Funktion. Damit kannst du dir deine Lösung basteln :)

Ungefähr sowas:

WENN(ISTFEHLER(FINDEN("5-Gang";A2)>0);WENN(ISTFEHLER(FINDEN("6-Gang";A2)>0);;Automatik);"Automatik")

Keine passende Antwort gefunden?

Fragen Sie die Community

Weitere Fragen mit Antworten