Frage von dukeball, 23

Hallo Zusammen, brauche hilfe bei Excel bedingte Formatierung Ferien TEIL 2?

Hallo Zusammen, brauche hilfe bei Excel bedingte Formatierung Ferien?

habe die Frage bereits gestern gestellt und von Chris auch eine Antwort erhalten. Habe nun diese Datei hochgeladen und bitte um weitere Unterstützung.

ich habe 2 Bilder eingefügt das eine soll jetzt den Monat Dezember darstellen und in der anderen Registerkarte sind die Ferien hinterlegt. Jetzt sollen im Dezember alle Spalten markiert (bedingte Formatierung) werden die zum Beispiel den Ferienzeitraum 02.12.2017 bis 05.12.2017 und 10.12. - 15.12.2017.

!!! Es soll nicht nur die Zelle mit dem Datum markiert werden, sondern auch die Felder darunter!!!

Ich habe keine VBA-Kenntnisse

Für die Feiertage habe ich das hinbekommen.

Hilfreichste Antwort - ausgezeichnet vom Fragesteller
von Ninombre, Community-Experte für Excel, 20
=UND(B$5>=SVERWEIS(B$5;Tabelle1!$E$2:$E$3;1;WAHR);B$5<=SVERWEIS(B$5;Tabelle1!$E$2:$F$3;2;WAHR))

Wenn das Tabellenblatt mit Feiertagen und Ferien nicht Tabelle1 heißt, musst Du das noch anpassen - wenn weitere Ferieneinträge kommen auch den Bereich, der bislang E2:F3 ist

Wichtig ist, dass die Ferien hinsichtlich Datum aufsteigend sortiert sind, sonst funktioniert der sverweis mit ungefährem Treffer nicht.

Alternative Formel:

=SUMMENPRODUKT((Tabelle1!$E$2:$E$2<=B$5)*(Tabelle1!$F$2:$F$2>=B$5))=1

Da sollte die Reihenfolge egal sein und wäre daher ratsamer.
Die erste Variante kam mir irgendwie zuerst in den Sinn, darum steht sie trotzdem hier.

Kommentar von Ninombre ,

=ZÄHLENWENN(Tabelle1!$B$1:$B$10;B$5)>0

wäre eine Lösung für die Feiertage, wobei Du die ja wohl schon abgefragt hast.

Wenn nicht zwischen Feiertagen und Ferien optisch unterschieden werden muss, reicht eine bedingte Formatierung

=oder(SUMMENPRODUKT((Tabelle1!$E$2:$E$2<=B$5)*(Tabelle1!$F$2:$F$2>=B$5))=1;ZÄHLENWENN(Tabelle1!$B$1:$B$10;B$5)>0) 
Antwort
von qugart, 21

Dann mach es genauso wie bei den Feiertagen.

Kommentar von Ninombre ,

Ferien sind, anders als die Feiertage, ein Zeitraum. Da reicht es nicht ein einzelnes Datum abzufragen.

Keine passende Antwort gefunden?

Fragen Sie die Community

Weitere Fragen mit Antworten