Frage von carlo1985, 76

Hallo, wie kann ich in Splalte C eine Formel einbauen, in der es die Zahlen in Splate B in Zelle A1 sucht und wenn es diesen findet dann in Spalte C wiedergibt?

Hilfreichste Antwort - ausgezeichnet vom Fragesteller
von Britzcontrol, 12

(Neue Antwort wegen des eingefügten Bildes)

So, ich glaub, es ist geschafft:

Diese Formel in C1 und runterziehen

=WENN(ZÄHLENWENN(B:B;TEIL(A2;FINDEN(".";A2;1)-1;3))>0;TEIL(A2;FINDEN(".";A2;1)-1;3);"--")

Ggf die zwei Leerstriche zwischen den Anführungszeichen durch eine Leerstelle ersetzen.

Ist damit die Frage zufriedenstellend beantwortet?

Gruß aus Berlin

Kommentar von carlo1985 ,

Vielen Dank. Das war genau das was ich wollte.

Kommentar von Britzcontrol ,

Bitte, gerne.
Dank für die Auszeichnung.

Gruß aus Berlin

Antwort
von Rubezahl2000, 42

Schreib in C1 diese Formel:

=WENN(ZÄHLENWENN(A1;"*"&B1&"*")>0;B1;"")

Wenn der Inhalt von B1 irgendwo innerhalb des Textes in A1 vorkommt, dann liefert diese Formel den Inhalt von B1;
wenn der Inhalt von B1 nirgendwo in A1 vorkommt, dann liefert diese Formel nichts.
Ist es das, was du brauchst?

Anschließend die Formel in Spalte C runterkopieren.

Kommentar von carlo1985 ,

Vielen Dank erst mal. Leider nein.

Wenn der Inhalt von B1 oder B2 oder B3..bis B11 in A1 vorkommt, dann soll es nur diesen gefundenen Wert in C1 raus spucken (z. B. 1.2). Findet es diesen Wert nicht dann soll in C1 gar nichts stehen.

Zur Info der Wert in A1 hat keinen fixen Platz. D. H. beispielsweise die Zahl 1.2 kann am Anfang, in der Mitte oder am Ende des Textes stehen.

 

Kommentar von Rubezahl2000 ,

Achso, du willst in Zelle C1, gleichzeitig ALLE Zellen aus Spalte B mit Zelle A1 vergleichen und denjenigen Wert aus Spalte B anzeigen, der in A1 enthalten ist?
Verstehe ich das jetzt richtig?

Meine Formel hat zeilenweise verglichen, weil ich das so verstanden hatte.

Kommentar von carlo1985 ,

genau richtig erfasst

Kommentar von Rubezahl2000 ,

Hat denn "meine" Formel bei dir zumindest insoweit funktioniert, dass sie erkannt hat, wenn B1 irgendwo in A1 vorkommt?
Das wäre ja schon mal ein 1. Schritt :-)
Jetzt aber mehrere Zellen aus Spalte B gleichzeitig mit A1 zu vergleichen, da fällt mir als Lösungsweg nur ein Makro oder eine Hilfstabelle ein.

Kommentar von carlo1985 ,

ne leider nicht. da bekomme ich den Wert 1.0 in C1. Obwohl in A1 " Mercedes A-Klasse 1.2 mit AHK" steht...

 

Antwort
von Britzcontrol, 50

Wenn die Zahlen, die Du suchst immer die letzten Stellen sind, dann

=RECHTS(A1;3)

Die zeigt die letzten drei Stellen "1.2" aus A1 an.

Gruß aus Berlin

Kommentar von carlo1985 ,

Vielen Dank für die schnelle Antwort aber leider nicht. Denn es kann auch sein, dass die Zahlen in Zelle A1 zwischen den Text steht. Das heisst, es hat keinen fixen Platz in der Zelle.

Kommentar von Britzcontrol ,

Dann solltetst Du mal alle möglichen Kombinationen aufzeigen.
So, ohne nähere Informationen, wäre eine Hilfe lediglich ein stochern in einem großen Kontingent an Lösungsmöglichkeiten.

Gruß aus Berlin

Kommentar von carlo1985 ,

Ok dann versuch ich es mal.

In Zelle C1: es soll in Zelle A1 gucken, ob irgend eine Zahl aus B1 bis B11 vorkommen. Wenn ja (hier 1.2) dann soll es diesen Wert (1.2) in Zelle C1 raus spucken ansosten "Keinene Eintrag". Das gleich auch in C2 usw... 

Beispiel:

A1: Mercedes A-Klasse 1.2 mit Navi

A2: Ford Focus 2.0 Ohne Navi mit AHK

A3: Ford Fiesta mit Navi 1.6 ohne AHK

 

B1: 1.0

B2: 1.1

B3: 1.2

B4: 1.3

C1: soll die gesuchte Formel rein

C2: soll die formel von C1 weiter fort gesetzt werden

Antwort
von Ghanasoccer, 29

Schreibe in C1 rein:

=WENN(B1=RECHTS(A$1;3);A$1;"")

Wenn du willst dass der wert aus der Spalte B:B angezeigt wird schreib statt dem zweiten A$1 einfach B1 ok?

Keine passende Antwort gefunden?

Fragen Sie die Community