Frage von ReifenKoeln, 47

Hallo Wer kann mir helfen, ich möchte eine Excel Tabelle erstellen in der eine Euro Betrag in in Buchstaben gewandelt wird?

.Beispiel 123,00 Euro soll ergeben KOR 1234567890 KORTENBACH jede Ziffer ist einem Buchstaben zugerdnet. Nachkommastellen werden ingnoriert.

Antwort
von Jackie251, 47

Excel ist sogesehen ein umfangreicher Taschenrechner.
Die Excelprofis helfen dir sicher gern, ein mathematischen Algorythmus in Excel umzusetzen.
Diesen Algorịthmus solltest du zunächst haben. Ansonsten frage bei den Mathematiker oder geben hier soviel Informationen, dass dabei ein Sinn herauskommt.

Antwort
von Jackie251, 38

Das könnstet du mit der recht aufwändigen Verkettung

=WECHSELN(WECHSELN(WECHSELN(WECHSELN(WECHSELN(WECHSELN(WECHSELN(WECHSELN(WECHSELN(WECHSELN(A2;1;"K");2;"O");3;"R");4;"T");5;"E");6;"N");7;"B");8;"A");9;"C");0;"H")

erreichen. Aufwändig weil Textfunktionen keine Arrays unterstützen

Kommentar von ReifenKoeln ,

Das mit den 3 Stellen stimmt, reicht mir aber für meine Anwendung, Danke für die Hilfe.

Antwort
von Britzcontrol, 41

Da ich immer der Meinung bin: EXCEL kann alles, hier die Lösung (soll aber zum Weiterdenken anregen):

=SVERWEIS(GANZZAHL(A1/100);Dat;2)&SVERWEIS(GANZZAHL((A1-GANZZAHL(A1/100)*100)/10);Dat;2)&SVERWEIS(REST(A1;10);Dat;2)

Einzelheiten siehe Bild.

Gruß aus Berlin

Kommentar von Jackie251 ,

Das wird nicht funktionieren, weil es ausschließlich mit 3 Stelligen Beträgen geht

Kommentar von Britzcontrol ,

... und genau das ist der Punkt, der den Fragesteller zum Weiterdenken anregen soll.

Gruß aus Berlin

Antwort
von Herb3472, 40

Leider ist mir nicht klar, was Du genau meinst. Worin besteht die Zuordnung zwischen dem Betrag und dem Text rechts?

Kommentar von FGO65 ,

1 = K
2 = O
3 = R
usw.

Kommentar von Herb3472 ,

Du müsstest ein Array schaffen, in welchem jeder Ziffer ein Buchstabe fix zugeordnet ist. Das wäre eine typische Aufgabe für VBA, allerdings ist eine derartige Verschlüsselung sehr leicht zu knacken.

Und was bedeutet dann das "1234567890 KORTENBACH" nach "KOR"? Woraus wird das generiert?

Kommentar von ReifenKoeln ,

In diesem Beispiel entspricht die Ziffer 1 dem K aud dem Wort Kortenbach

KORTENBACH hat 10 Buchstaben K=1,O=2,R=3 ..... usw Eingabe 123 gleich KOR....

Antwort
von ReifenKoeln, 42

Ja genau so, aber ich möchte in einem Feld den Betrag z.b. 123 (Euro) eingeben, und in einem anderen Feld soll dann KOR ausgegeben werden..Der wunsch ist einen EK Preis in Buchstaben zu verschlüsseln.

Antwort
von ReifenKoeln, 44

In diesem Beispiel entspricht die Ziffer 1 dem K aud dem Wort Kortenbach

KORTENBACH  hat 10 Buchstaben K=1,O=2,R=3  ..... usw Eingabe 123 gleich KOR....

Kommentar von Herb3472 ,

Ich steh ehrlich gesagt auf der Leitung. Du kannst sicherlich jeder Ziffer einen Buchstaben zuordnen, aber was hat der Betrag von € 123,00 direkt und unmittelbar mit KOR...tenbach zu tun?

Sieh Dir einmal die Codetabelle vom ASCII-Code an, da siehst Du, wie z.B: Buchstaben durch Zahlen repräsentiert werden:

https://de.wikipedia.org/wiki/American\_Standard\_Code\_for\_Information\_Interc...


Antwort
von FGO65, 44

Nö, geht nicht

Keine passende Antwort gefunden?

Fragen Sie die Community

Weitere Fragen mit Antworten