Frage von pklingenberg, 30

Hallo und guten Tag, ich bin neu hier und bitte um Hilfe für mein Problem: ?

Wert in A1 1000

Wert in A2 15

Wert in A3 100

Wert A1 soll in Schritten von 1 bis A3 mit A2 addiert werden, jeder siebte Wert soll in Zelle B1 bis B.. ausgewiesen werden.

Zelle B1=( A1+( 7*A2)Zelle B2=( B1+(7*A2)Zelle B3=(b2+(7*A2)....usw

Danke schon mal für eure Hilfe

Paul

Antwort
von Ninombre, 11

Die Fragestellung ist ehrlich gesagt recht verwirrend: Du hast die Formel doch eigentlich schon genannt. Wenn Du sie einfach von links nach rechts ziehen bzw. kopieren willst, musst Du nur $A2 verwenden, damit der Zellenbezug sich nicht beim kopieren verändert. Das andere Problem ist ja, zu berechnen wie oft man diese Schritte wiederholen muss. 100/7 geht nicht glatt auf, also runden(100/7;1) = 14 Mal. Das kannst Du in eine wenn-Formel bringen

B1 ist wie von Dir schon genannt = A1+7*A2
B2 bis Bxx =WENN(ZEILE(B2)<=RUNDEN($A$3/7;0);B1+7*$A$2;"")

Damit prüft man dann, ob die Zeile noch berechnet werden muss oder nicht. Zeile 14 wäre noch dabei, Zeile 15 eben nicht mehr.

In den Themen nennst Du allerdings VBA und For - Next. Soll das per VBA gelöst werden?

Da bleibt das Problem mit der Anzahl von Wiederholungen, ist aber auf die gleiche Art zu lösen:
For i = 1 To (Round(Cells(3, 1).Value / 7, 0))

Keine passende Antwort gefunden?

Fragen Sie die Community

Weitere Fragen mit Antworten