Frage von xIXxDanixXIx, 39

Hallo Leute ich habe erst einmal ein Plugin selber programmiert (Mein 1. Plugin soll nur 2 Textnachrichten ausgeben), aber es geht nicht mehr?

Also ich habe ein Plugin geschrieben, welches nur 2 Textnachrichten ausgeben soll. Das habe ich auch hinbekommen und habe es noch auf meinem Localhost Server getestet. Der Localhost Server läuft auf der 1.8 Spigot. Jetzt wollte ich es auf meinem eigentlichen Server verwenden, aber es wird da einfach nicht angenommen es kommt auch keine Nachricht in der Console, dass es enabled wurde. Den Server, wo es nicht funktioniert hoste ich auf Mchost 24 auf der gleichen Version.

Antwort
von applica, 39

Vielleicht hast du auf den Server Pluins installiert, die dein eigenes nicht anerkennen und sie somit nicht harmonieren können :o :D

Kommentar von ErrorUnbekannt ,

Ich denke eher das sein Plugin auf Java 8 ist und der Hoster nur Java 7 unterstützt

Antwort
von ErrorUnbekannt, 25

Du giebst hier zu wenig Infos vllt. Mal den log vom nicht funktionierenden Server

Kommentar von xIXxDanixXIx ,

Das Problem ist ja dass da 0 drinnen steht(also von diesem plugin)... muss ich vll. Eine Config machen oder muss das pl einen Ordner erstellen dass funktioniert?

Kommentar von ErrorUnbekannt ,

Im Ordner des Servers giebt es einen Logs Ordner dort ist ein latest.log das würde helfen

Kommentar von xIXxDanixXIx ,

Ok ich kenn den ordner, kann heute aber leider nicht mehr zum pc würdest du mir morgn auch noch helfen ^^

Kommentar von ErrorUnbekannt ,

Ja schreib einfach hier drunter ich sollte es sehen

Kommentar von ErrorUnbekannt ,

Also ist das Problem immernoch da?

Kommentar von xIXxDanixXIx ,

[22:04:57] [Server thread/ERROR]: Could not load 'plugins/PXLStorm.jar' in folder 'plugins'org.bukkit.plugin.InvalidPluginException: java.lang.UnsupportedClassVersionError: me/pxlstorm/main/main : Unsupported major.minor version 52.0at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.java:135) ~[spigot-1.8.x.jar:git-Spigot-d2856ae-8f0f4ed]at org.bukkit.plugin.SimplePluginManager.loadPlugin(SimplePluginManager.java:329) ~[spigot-1.8.x.jar:git-Spigot-d2856ae-8f0f4ed]at org.bukkit.plugin.SimplePluginManager.loadPlugins(SimplePluginManager.java:251) [spigot-1.8.x.jar:git-Spigot-d2856ae-8f0f4ed]at org.bukkit.craftbukkit.v1_8_R3.CraftServer.loadPlugins(CraftServer.java:291) [spigot-1.8.x.jar:git-Spigot-d2856ae-8f0f4ed]at net.minecraft.server.v1_8_R3.DedicatedServer.init(DedicatedServer.java:198) [spigot-1.8.x.jar:git-Spigot-d2856ae-8f0f4ed]at net.minecraft.server.v1_8_R3.MinecraftServer.run(MinecraftServer.java:528) [spigot-1.8.x.jar:git-Spigot-d2856ae-8f0f4ed]at java.lang.Thread.run(Thread.java:745) [?:1.7.0_79]Caused by: java.lang.UnsupportedClassVersionError: me/pxlstorm/main/main : Unsupported major.minor version 52.0at java.lang.ClassLoader.defineClass1(Native Method) ~[?:1.7.0_79]at java.lang.ClassLoader.defineClass(ClassLoader.java:800) ~[?:1.7.0_79]at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:142) ~[?:1.7.0_79]at java.net.URLClassLoader.defineClass(URLClassLoader.java:449) ~[?:1.7.0_79]at java.net.URLClassLoader.access$100(URLClassLoader.java:71) ~[?:1.7.0_79]at java.net.URLClassLoader$1.run(URLClassLoader.java:361) ~[?:1.7.0_79]at java.net.URLClassLoader$1.run(URLClassLoader.java:355) ~[?:1.7.0_79]at java.security.AccessController.doPrivileged(Native Method) ~[?:1.7.0_79]at java.net.URLClassLoader.findClass(URLClassLoader.java:354) ~[?:1.7.0_79]at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:101) ~[spigot-1.8.x.jar:git-Spigot-d2856ae-8f0f4ed]at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:86) ~[spigot-1.8.x.jar:git-Spigot-d2856ae-8f0f4ed]at java.lang.ClassLoader.loadClass(ClassLoader.java:425) ~[?:1.7.0_79]at java.lang.ClassLoader.loadClass(ClassLoader.java:358) ~[?:1.7.0_79]at java.lang.Class.forName0(Native Method) ~[?:1.7.0_79]at java.lang.Class.forName(Class.java:274) ~[?:1.7.0_79]at org.bukkit.plugin.java.PluginClassLoader.(PluginClassLoader.java:64) ~[spigot-1.8.x.jar:git-Spigot-d2856ae-8f0f4ed]at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.java:131) ~[spigot-1.8.x.jar:git-Spigot-d2856ae-8f0f4ed]... 6 more

Das wär der Teil mit dem Plugin [PXLStorm]

Kommentar von ErrorUnbekannt ,

Okay du hast das Plugin anscheinend auf Java 8 geschrieben und dein seeve läuft auf Java 7 du musst dir also jdk 7 runterlasen und die version deines Projektes ändern

Keine passende Antwort gefunden?

Fragen Sie die Community