Frage von 90aissurob, 58

Hallo kann mir jemand beim Programmieren in Excel helfen?

Die Excel-Experten sind gefragt: Ich bräuchte einen Button der beim Betätigen folgende Funktion ausführt:

  1. A1 + B1 + C1 + D1 zusammen rechnet,
  2. das Ergebnis in E1 schreibt

Das ganze müsste noch mit dem aktuellen Datum verknüpft sein, sodass der Button beim Betätigen am 01.01.2016 das Feld E1 ausfüllt, am 02.01.2016 das Feld E2, am 03.01.2016 das Feld E3 usw.

Weiterhin müsste der Button beim Betätigen das Ergebnis immer mit dem des Vortages vergleichen und die Differenz in jeweils das nächste Feld sprich F1, F2, F3 usw. schreiben.

Das Ganze soll dazu dienen, das man sich eine Kurve anzeigen lassen kann, die die Veränderung von Tage zu Tag anzeigt (Trendlinie). Man soll sozusagen nur jeden Tag die 4 Felder (A1-A4) füllen und den Button betätigen und der Rest geschieht automatisch. --> das wäre perfekt!

Vielen Dank für hoffentlich Hilfreiche Antworten :)

Expertenantwort
von Suboptimierer, Community-Experte für Excel, 45

Ich sehe auf dem ersten Blick nicht die Notwendigkeit eines Buttons...

Ich versuche dir mal etwas zu basteln...

Kommentar von 90aissurob ,

Der Button soll nur der Einfachkeit halber bzw. des Komfort dienen ;) ich habe aber ka ob man das auch ohne Button regeln kann. Mit wäre mit lieber :) aber Danke schonmal!

Kommentar von Suboptimierer ,

E1: =SUMME(A1:D1)
F2: =E2-E1

Beides herunterziehen.

Der einzige Unterschied zu deiner Anforderung ist, dass die Eingaben am ersten Tag in A1:D1 getätigt werden, am zweiten Tag in A2:D2 and so on.

Wenn du willst, kannst du sogar prüfen, ob A1:D1 gefüllt ist und nur in diesem Fall summieren: =WENN(A1&B1&C1&D1<>"";<Formel>;"")

Kommentar von 90aissurob ,

Okay vielen Dank erstmal. Soweit absolut verständlich...

Ist die Geschichte mit dem Button auch möglich, das man die Excel-Datei sozusagen nutzen kann wie ein Programm?

Ich würde gerne das man die 4 Felder ausfüllt und dann berechnen lässt. Das "Programm" müsste halt erkennen welcher Tag ist und es in das entsprechende Feld das Ergebnis schreiben... auch wenn man einen Tag auslässt. Es müsste dann halt die Differenz vom letzen berechneten Ergebnis zum aktuellen nehmen...

Kommentar von Suboptimierer ,

Joa, das geht auch, macht es allerdings unnötig kompliziert, wie ich finde.

Das Tagesdatum kriegst du mit Date(), die letzte befüllte Zeile bekommst du mit Range("E1").End(xlDown).Offset(1,0), die Summe über .Offset(0,-4).Value + .Offset(0,-3).Value... und die Differenz zum Vorwert auf ähnlichem Weg. Wenn du willst, kannst du natürlich auch eine Schleife bauen.

Wenn das keine Übung für VBA ist, wäre es mir den Aufwand nicht wert.

Kommentar von 90aissurob ,

Okay ich schau mal ob ich mich da irgenwie rein fuchsen kann.... Vielen Dank für deine Hilfe!!!

Antwort
von AppleIPhone7, 41

Machst du eine Ausbildung und wenn ja wo, oder muss man das als Student beherrschen? Allgemein brauchst du ja die Excel Tabelle. 

Kommentar von 90aissurob ,

ich studiere und möchte eine Befragung damit auswerten.

Antwort
von Sorrisoo, 33

Müsste mit der Makro Aufzeichnung zu machen sein. Google mal danach.  

Keine passende Antwort gefunden?

Fragen Sie die Community

Weitere Fragen mit Antworten