Hallo gibt es eine Möglichkeit, in Excel eine Art Suchfunktion durch die Wenn-Funktionen zu erstellen?

... komplette Frage anzeigen

4 Antworten

Das geht, aber nicht mit einfacher WENN-Funktion. Trage in E2 folgende Formel ein, schließe die Eingabe mit [Strg] + [Shift] + [Enter] ab und zieh sie herunter.

=WENNFEHLER(INDEX($A$2:$A$100;KGRÖSSTE(ZEILE($B$2:$B$100)*($B$2:$B$100<$E$1)*($C$2:$C$100>$E$1)-1;ZEILE(A1)));"")
Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von Oubyi
24.08.2016, 13:55

DH!
Ich löse das immer etwas anders (aber aufwendiger) und habe dadurch die Name in der "richtigen" Reihenfolge:

{=WENNFEHLER(INDEX($A$1:$A$100;KKLEINSTE(WENN((($B$2:$B$100<$E$1)*($C$2:$C$100>$E$1));ZEILE($2:$100));ZEILE(A1)));"")}

2

Wenn die Formel, die Suboptimierer beschrieben hat, zu kompliziert erscheint, dann kannst Du dafür auch den normalen Autofilter verwenden.
Wenn die Suchlogik mit dem normalen Filter nicht abgedeckt werden kann, lässt sich das mit einer Hilfsspalte lösen, d.h. die Bedingungen, dass eine Zeile angezeigt werden soll, wird in der Hilfsspalte abgebildet und dann einfach auf diese Spalte gefiltert.

Angewendet auf das Datum (ich nehme an, dass das Datum in E1 größer Anfangsdatum und kleiner Enddatum sein muss, damit ein Name erscheinen soll), wäre die Formel für eine Hilfsspalte:
=UND(A1<=E$1;B1>=E$1)

Das liefert Wahr und Falsch, Du filterst dann einfach auf Wahr und hast die entsprechenden Namen.

Antwort bewerten Vielen Dank für Deine Bewertung

Das ist ein typisches Beispiel für eine Datenbankabfrage - genau dafür gibt es im Office Paket "Access". Da kannst du exakt solche Dinge in wenigen Klicks mit machen. Excel ist für solche Dinge ungeeignet (was nicht heißt, dass es unmöglich ist).

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von Iamiam
24.08.2016, 14:43

wenn man es schon kann, ja. Wenn man es erst lernen muss: nein

Das beste Programm ist normalerweise das, in dem ich mich auskenne, sofern es da überhaupt geht, auch wenns Besseres gibt.

Oder würdest Du Oracle lernen, weil da ein paar Dinge einfacher gehen, die in Access nur umständlich gehen?

Was anderes wäre, wenns gar nicht ginge oder EXTREM UMSTÄNDLICH.

0

Vielen Dank an alle, leider hat das ganze mit meinem Excel-Wissen dann doch nicht hingehauen, sodass ich zu einer einfachen Anzeige neben den jeweiligen Spalten übergegangen bin. =WENN((B2<=F$1)*UND(C2>=F$1);A2;"")

Access finde ich für meine Zwecke unpraktisch, da ich gerne sämliches in einer Tabelle hätte. Trotzdem danke für den Hinweis.

Antwort bewerten Vielen Dank für Deine Bewertung