Frage von derbokas, 22

Habe ein Update bei Wordpress vorgenommen (Theme Update) nun kommt immer folgendes wenn ich die Seite aufrufe:?

Parse error: syntax error, unexpected end of file, expecting ')' in /customers/7/4/6/digreen.de/httpd.www/wp-content/themes/_make/assets/php/tgm/tgm.php on line 1

Das ist die Datei was ist falsch ?

<?php require_once dirname( __FILE__ ) . '/class-tgm-plugin-activation.php';add_action( 'tgmpa_register', 'make_register_required_plugins' );function make_register_required_plugins() { $plugins = array( // This is an example of how to include a plugin pre-packaged with a theme array( 'name' => 'Revolution Slider', // The plugin name 'slug' => 'revslider', // The plugin slug (typically the folder name) 'source' => get_stylesheet_directory() . '/assets/php/plugins/revslider.zip', // The plugin source 'required' => false, // If false, the plugin is only 'recommended' instead of required 'version' => '', // E.g. 1.0.0. If set, the active plugin must be this version or higher, otherwise a notice is presented 'force_activation' => false, // If true, plugin is activated upon theme activation and cannot be deactivated until theme switch 'force_deactivation' => false, // If true, plugin is deactivated upon theme switch, useful for theme-specific plugins 'external_url' => '', // If set, overrides default API URL and points to an external URL ), array( 'name' => 'LayerSlider WP', 'slug' => 'LayerSlider', 'source' => get_stylesheet_directory() . '/assets/php/plugins/layerslider.zip', 'required' => false, 'version' => '5.0.2', 'force_activation' => false, 'force_deactivation' => false ), array( 'name' => 'Post Types Order', 'slug' => 'post-types-order', 'required' => false, 'force_activation' => false, ), array( 'name' => 'WP Post Formats', // The plugin name 'slug' => 'vafpress-post-formats-ui-develop', // The plugin slug (typically the folder name) 'source' => get_stylesheet_directory() . '/assets/php/plugins/wp-post-formats-develop.zip', // The plugin source 'required' => true, // If false, the plugin is only 'recommended' instead of required 'version' => '', // E.g. 1.0.0. If set, the active plugin must be this version or higher, otherwise a notice is presented 'force_activation' => false, // If true, plugin is activated upon theme activation and cannot be deactivated until theme switch 'force_deactivation' => false, // If true, plugin is deactivated upon theme switch, useful for theme-specific plugins 'external_url' => '', // If set, overrides default API URL and points to an external URL ), ); $theme_text_domain = 'inesta'; $config = array( 'domain' => $theme_text_domain, // Text domain - likely want to be the same as your theme. 'default_path' => '', // Default absolute path to pre-packaged plugins 'parent_menu_slug' => 'themes.php', // Default parent menu slug 'parent_url_slug' => 'themes.php', // Default parent URL slug 'menu

Antwort
von Sawascwoolf, 22

Vermutlich wurde das Update unterbrochen, lade das Design erneut runter und lade die Daten mittels eines FTP-Programmes erneut hoch.

Mit etwas Glück reicht das schon, ansonsten ist noch nicht alles verloren, also man kann die Installation vermutlich noch retten. Wenn mein Tipp nicht hilft melde dich bei mir.

Kommentar von derbokas ,

Danke geht wieder :)

Antwort
von Attacktic, 18

Mhhh... Du hast es dir zerhackt ;-) Hoffe du hast noch nen Backup oder die Administration von der Seite ab gekoppelt... Ansonsten... Viel Spaß beim neu installieren

Antwort
von derbokas, 6

Also ich habe nun einfach das Theme gelöscht und neu installiert :) und alles ging wieder musste paar Sachen einstellen aber läuft :) Danke für die Hilfe

Antwort
von maximilianus7, 10

mein erster eindruck war, dass der GF-editor das alles zusammengeschoben hat (das macht er nämlich), aber die fehlermeldung sagt "... on line 1". als ob tatsächlich dein code in einer zeile steht, die zudem abgeschnitten wurde.

hast du den code binär runtergeladen und dein editor kam mit dem unix-textformat nicht zurecht? oder umgekehrt?

zeig uns mal auf z.b. http.//pastie.org wie dein code wirklich aussieht, eh wir noch weiter spekulieren. 

Keine passende Antwort gefunden?

Fragen Sie die Community