Frage von Schuettong, 62

Zwei Spalten Zeilenweise überprüfen und zählen

Guten Tag,

ich möchte gerne zwei Spalten miteinander Zeilenweise vergleichen. Ich habe zwei Spalten, in der einen ist ein Notensystem von 1-5, in der anderen eine Bewertung ( oft, manchmal, selten und nie). Nun möchte ich alle Zeilen gezählt haben die links eine 5 oder 4 haben un rechts eine oft oder manchmal steht. Dann einmal die 3,2,1 mit selten und nie. Die dritte Zahl sollte dann die restlichen Zeilen zählen die nicht zusammenpassen. Ist das möglich?

Hilfreichste Antwort - ausgezeichnet vom Fragesteller
von Oubyi, Community-Experte für Excel, 21

Angenommen, die Spalten sind A und B, dann:

C1: =SUMMENPRODUKT(((A1:A100)>3)*(((B1:B100)="oft")+((B1:B100)="manchmal")))

D1: =SUMMENPRODUKT(((A1:A100)<4)*(((B1:B100)="selten")+((B1:B100)="nie")))

E1: =ANZAHL(A1:A100)-C1-D1

Teste mal genau.
Für die Rest-Formel in E1 muss die Tabelle ordentlich ausgefüllt sein.
Alternativ könnte man auch eine Formel à la C1/D1 dafür nehmen.
Hilft Dir das weiter?

Kommentar von Oubyi ,

Danke fürs

Antwort
von AbbathFangirl, 27

Nur eine Verständnisfrage:

Du hast ein Notensystem von 1 - 5 aber dazu nur vier Bewertungen:

  • oft = 5
  • manchmal = 4
  • selten = 3
  • nie = 2
  • ? = 1
Kommentar von Schuettong ,

ne die sind unabhänig voneinander die erste Spalte ist die

Bewertung der Kundebetreuung die wurde in Noten abgefragt. (1-5)

Die zweite Spalte ist die Antwort auf die Frage ob man etwas im Laden angeschaut hat und dann im Internet gekauft hat. ( Nie, Selten, Manchmal, Oft)

ich möchte nun rausfinden, wer bei Kundenzufriedenheit eine 5 oder 4 angegeben hat und bei der Frage im Internet gekauft mit Oft und Manchmal geantwortet hat.

Habe es jetzt so probiert:

=WENN(ODER(A2>2;B2="Manchmal";B2="Oft");1;0)

Das klappt aber nicht weil er auch eine Eins schreibt wenn da Selten angegeben ist.

Antwort
von arminho1, 22

Kannst du mit der Funktion ZÄHLENWENNS machen.

Kommentar von arminho1 ,

Jetzt konkreter, da ich gestern nicht am PC war:

Voraussetzung: Deine Werte stehen in den Spalten A + B:

=ZÄHLENWENNS(A:A;">3";B:B;"oft")+ZÄHLENWENNS(A:A;">3";B:B;"manchmal")

=ZÄHLENWENNS(A:A;"<4";B:B;"selten")+ZÄHLENWENNS(A:A;"<4";B:B;"nie")

Der Rest:

=ANZAHL(A:A) abzüglich die oberen beiden Werte

Keine passende Antwort gefunden?

Fragen Sie die Community

Weitere Fragen mit Antworten