Frage von Excelnewbie1, 106

Ich möchte gerne das Excel mir die Zahl in Prozent ausgibt sobald 100.000$ überschritten sind?

Beispiel: Ein Investitionssumme von 80.000$ plus dem Gewinn von 25.525$ überschreiten die von mir gesetzte 100.000$ Grenze. Jetzt würde ich gerne die Differenz (also hier 5.525$) in % angeben und die Differenzsumme, die 5525$ dann als Überschusssumme in einer separaten Spalte darstellen.

Vielleicht hat jemand eine Formel Griffbereit... Zwar ist mir der Weg Klar, ich weiss aber nicht wie es umzusetzen ist.

Vielen Dank für eure Hilfe...

Expertenantwort
von Iamiam, Community-Experte für Excel, 46

ich weiß nicht, ob ich dich richtig verstehe: Du möchtest Gewinne <100.000 in $ ausgewiesen haben und >=100.000 in % mit 100.000=100% ?

Da kann diese Formel helfen:

=WENN((A1)/100000-1<0;(A1);TEXT((A1)/100000-1;"0,00%"))

Formatierst Du sie noch mit diesem Format (Ben-def, nicht bedingtes!):

"Gewinn: "#.##0 $;[Rot]"Gewinn: "-#.##0 $;"Gewinn: Null!";"Gewinn: "@

wird sie unverwechselbar, d.h., Du siehst sofort, wenn Du das Format versehentlich woanders hin übertragen hast und -vor allem- sie wird "sprechend"! Darüberhinaus wird die Zahl wiederverwertbar mit der Formel:

=WENN(ISTTEXT(B1);B1*100000;B1)

Da könnte es aber besser sein, gleich auf A1 zuzugreifen  (oder die Formel, die A1 ergibt). Natürlich kannst Du alle A1 ebenfalls mit so einer Formel substituieren (natürlich dann in Klammern setzen).

Frag ggf nochmal zurück!

(ich hab jetzt noch schnell € zu $ verändert und nicht mehr testen können, in meinem getesteten Original sind also € statt $ eingesetzt)

Kommentar von Excelnewbie1 ,

Das sieht schon Klasse aus, ich muss allerdings gestehen... So recht weiter bringt mich das nicht...
Ich glaube ich habe das nicht richtig erklärt was ich brauche...

http://www.bilder-upload.eu/show.php?file=417654-1461675589.png

Sobald die Summe Gesamt 100.000 $ überschreitet, soll er im Prinzip rechts den Überschuss und daneben automatisch die Prozente ausgeben. Die Tabelle ist dann am Ende... also im Prinzip sollte ab da nach unten alles leer bleiben... Aber das ist eine andere Frage denke ich. Im Moment mache ich das so: =WENN(K9>1;0;E9*H9)

Ich denke das muss eine verschachtelte Bedingung sein?

Kommentar von dkilli ,

Ich verstehe jetzt nicht mehr die einzelne Spalten und Zeilen

Wie werden die Provisionen, Gewinn,Summe Gesamt berechnet?

Wie kommst du auf die geraden Prozentzahlen und Betrag?

Kommentar von dkilli ,

Eine interessante Lösung. Wenn man mit dem Ergebnis rechnen will, so muss die Formel etwas geändert werden. 

=WENN((A1)/100000-1<0;(A1);WERT(TEXT((A1)/100000-1;"0,00%")))

Damit braucht man die 2. Formel.nicht

Die Spalte wo die Formel steht als Prozent formatieren.

Kommentar von Excelnewbie1 ,

https://www.dropbox.com/s/bryr2ocurw8d940/Berechnung-4.xlsx?dl=0

Ich gebe dir hier mal den link wo ich die Datei hinterlegt habe. Super nett von dir, das Du dich da so rein hängst.

Kommentar von Iamiam ,

hab mir jetzt zwar die dropbox runtergeladen, kommeaber vorr. heute und morgen nicht dazu, was zu machen - dazu müsste ich mich längere Zeit konzentrieren können, was erst mal nicht  geht, sorry!

Kommentar von dkilli ,

Leider geben die Zahlen dort überhaupt keinen Sinn.

Expertenantwort
von Suboptimierer, Community-Experte für Excel, 58

Überschuss: =MAX(0; Inv+Gew-Grenze)
Prozent: =Übersch*100/Grenze

Antwort
von dkilli, 59

Was soll denn 100% sein? 80000 oder 100000?

Kommentar von Excelnewbie1 ,

100.000

Kommentar von dkilli ,
Kommentar von dkilli ,

Sorry die Formel in D muss lauten Formel In D2 und Spalte D statt B2

Kommentar von dkilli ,

Revidiertes Bild (Heute bin ich nicht ausgeschlafen) 

http://www.bilder-upload.eu/show.php?file=32cec5-1461663785.png

Keine passende Antwort gefunden?

Fragen Sie die Community

Weitere Fragen mit Antworten