Frage von Azurcristall, 179

Google Tabellen - Pivot: #DIV/0! durch leere Zelle ersetzen?

Hallo zusammen,

gibt es in google Tabellen eine Möglichkeit, in einer Pivot Auswertung alle #DIV/0! auszublenden, also durch ein leeres Feld zu ersetzen?

Es geht nicht um ein NORMALES Feld mit einer normalen Formel (da ist mir klar, wie es geht), es geht nun spezifisch um Felder innerhalb einer Pivot Auswertung. In Excel gibt es die Funktion in den Optionen der Pivot Auswertung, in Google Tabellen finde ich leider keine derartigen Optionen.

Hier die Anleitung für EXCEL, vielleicht kennt jemand etwas analoges für google docs?

Ausblenden von Fehlerwerten in einem PivotTable-Bericht

Klicken Sie auf den PivotTable-Bericht.

Klicken Sie auf der Registerkarte Optionen in der Gruppe PivotTable-Optionen auf den Pfeil neben Optionen, und klicken Sie dann auf Optionen.

Klicken Sie auf die Registerkarte Layout & Format, und führen Sie dann eine oder mehrere der folgenden Aktionen aus:

Ändern der Fehleranzeige Aktivieren Sie unter Format das Kontrollkästchen Fehlerwerte anzeigen als. Geben Sie in das Feld den Wert ein, der anstelle von Fehlern angezeigt werden soll. Wenn bei Fehlern kein Wert angezeigt werden soll, löschen Sie alle Zeichen im Feld.

Ändern der Anzeige leerer Zellen Aktivieren Sie das Kontrollkästchen Leere Zellen anzeigen als. Geben Sie in das Feld den Wert ein, der in leeren Zellen angezeigt werden soll. Wenn kein Wert angezeigt werden soll, löschen Sie alle Zeichen im Feld. Zum Anzeigen von Nullen deaktivieren Sie das Kontrollkästchen.

Antwort
von Tron1701, 140

Hallo,

bei Excel ist es so, dass eine Division nur möglich ist, wenn der Divisor vorhanden ist (a:b=y).

Fehlt der Divisor, kann Excel die Division nicht durchführen, somit erhält man die Fehlermedung #DIV/0!.

Ansonsten kann man in Excel die Fehlermeldung folgendermaßen eleminieren.

Als Beispiel in A1 der Dividend (a), in B1 der Divisor (b), in C1 folgende Formel (für Ergebnis y).

Formel in C1 =WENN(B1="";"";A1/B1).

Vielleicht löst dies Dein Problem.

Gruß Tron

Keine passende Antwort gefunden?

Fragen Sie die Community