Frage von spontan80, 113

gewichteter Durchschnitt Excel - 2 Kriterien?

Ich habe eine Excel Liste, in Spalte A steht eine bestimmte Dauer (in Tagen), in Spalte B steht ein Betrag. Spalte A besagt, wie lange es dauert, den Betrag zu "erledigen". Nun sollte ich die durchschnittliche Dauer berechnen, allerdings gewichtet, also in Abhängigkeit vom Betrag. Da es ja z.B. bei 1 Euro nicht so "schlimm" ist, wenn dieser erst nach 100 Tagen geklärt wird. Hingegen ist es bei höheren Beträgen natürlich dringend. Wie kann ich das abbilden? Das Ergebnis sollte eben die durchschnittliche, gewichtete Dauer anzeigen. Danke schon mal!

Hilfreichste Antwort - ausgezeichnet vom Fragesteller
von Iamiam, Community-Experte für Excel, 88

Ganz verstehe ich die Aufgabe nicht, aber ich formuliere mal ein paar Gedanken dazu: Die Rückzahlungsquote für jeden einzelnen Betrag ist B/A in EURO/day

Die Gesamtrückzahlung aktuell ist Summenprodukt((B:B)*(A:A)^-1) Ändert sich nach Erledigung des ersten Betrags und nach jeder weiteren Beendigung, dafür kommen vllt neue hinzu.(Bräuchte dann aber in irgendeiner Form ein lfd Datum: ist morgen evtl anders und übermorgen wieder anders)

Die Wichtigkeit ist klar der höchste Wert von €/d, also KGrößte(Spalte €/d;1)

Was soll nun der Mittelwert sein? Mittlere Wichtigkeit = Mittlere Rückzahlung/d ?

Kannst auch Summenprodukt((B:B)*(A:A°-1))/Anzahl(B:B) nehmen

Oder Medianwert 50% der täglichen Rückzahlungen?

Vllt führen Dich diese Überlegungen auf die richtige Spur.

Kommentar von spontan80 ,

Danke für die Hilfestellung, konnte das "Problem" jetzt lösen.

Expertenantwort
von Suboptimierer, Community-Experte für Excel, 73

Nimm doch das arithmetische Mittel von Dauer / Betrag.

=MITTELWERT(A2:A8/B2:B8)

Durchschnittliche Dauer pro Euro.

Die Eingabe schließt du mit Strg + Shift + Enter ab.

Kommentar von spontan80 ,

Hallo, danke für die Antwort. :) Allerdings verstehe ich das nicht so ganz. Denn wenn ich jetzt z.B. bei gleichen Tagen (z.B. 31) verschiedene Beträge habe, dann wird der niedrigere Betrag höher gewichtet, als der höhere. Das kann doch nicht ganz stimmen, oder?

Danke schon mal im Voraus!!

Kommentar von Suboptimierer ,

Beispiel:

31 Tage 10 Euro entspricht 3,1 Tage pro Euro
31 Tage 100 Euro entspricht 0,31 Tage pro Euro

Im Schnitt benötigt etwas (3,1 + 0,31)/2 = 3,41 Tage pro Euro. Ein Euro ist im Schnitt in 3,41 Tagen "verbraucht".

Bei Zeiten und Arbeit muss man aufpassen. Manchmal verhält es sich umgekehrtproportional. Mehrere Arbeiter brauchen für eine Arbeit nicht so lange wie wenigere Arbeiter.

Du könntest versuchen, den Mittelwert über das Reziproke zu errechnen, also (31*10 + 31*100)/2 = 1705

Wie der Wert zu interpretieren ist, kann ich dir gerade allerdings auch nicht sagen. Das wäre das Schulnotenprinzip.

((1 * Anzahl Einsen) + (2 * Anzahl Zweien) + ... + (6 * Anzahl Sechsen)) / Anzahl Noten

Keine passende Antwort gefunden?

Fragen Sie die Community

Weitere Fragen mit Antworten