Frage von Azmainyr, 163

GBA DISPLAY MOD PROBLEM?

Hallo! Ich habe ein kleines Problem: Ich bin gerade dabei ein altes AGS-101 Backlight Display aus einem Gameboy Advance SP in einen normalen Gameboy Advance zu bauen. Mittlerweile habe ich die Display alle herausgebaut. Wenn ich jetzt das Display, mit dem passenden Adapter den ich bestellt habe, an das Motherboard vom Gameboy Advance anschließe, dann geht dieses Display zwar an, aber die Farben sind praktisch komplett verwaschen. Woran kann das liegen? Das Kabel vom SP ging übrigens auch ziemlich schwer in das des Adapters rein... Oder liegt das einfach daran, dass ich vom Flachband zum Motherboard keine Stromversorgung(?) gelötet habe?

Im Anhang findet ihr dann noch Bilder!

Antwort
von Switchguard, 111

Hallo Azmainyr, das Problem liegt meiner Vermutung nach am Modell der Hardware. Das zusätzliche Kabel anzubringen macht zwar den Bildschirm heller, korrigiert aber nicht die inkorrekte Farbdarstellung.

Beim Motherboard des GBA gibt es zwei Verschiedene Ausführungen:

40-Pin Motherboard (Seriennnummer beginnt mit 0) 32-Pin Motherboard (Seriennnummer beginnt mit 1)

Zusätzlich gibt es bei den Bildschirmen des GBA-SP AGS-101 auch zwei Varianten:

AB: hat einen braunes Verbindungsstück und unterschiedlich breite Leiterbahnen B: hat ein weißes Verbindungsstück und einheitlich breite Leiterbahnen

Siehe: https://gbatemp.net/threads/gba-backlight-agb-001.328487/page-44#post-5465938

Fazit: AB + 40-Pin = OK AB + 32-Pin = OK B + 40-Pin = Problem B + 32-Pin = OK

Ob ich damit richtig liege werde ich bald herausfinden, da ich seit gestern vor dem gleichen Spaß sitze ;)

Kommentar von Azmainyr ,

Hallo Switchgard!

Ich hab mir jetzt mal einen 32 Pinner bestellt und werde das Mainboard mal wechseln und dann mal schauen ob es dann funktioniert! Ich werde berichten!

Kommentar von Switchguard ,

Ich kann nun bestätigen, dass es mit der genannten Kombination (B + 32-Pin) funktioniert.

Keine passende Antwort gefunden?

Fragen Sie die Community