Frage von Nivaum, 72

Freunde können bei meinem Minecraft Spigot Server nicht joinen?

Hallo Leute, Ich habe eine Frage.Ich habe einen Spigot 1.8.8 Server mit Hamachi. 1. Meien Freunde können mit der IP nicht joinen.Ich aber schon. UND nein es liegt nich an FireWall, da ich OSX habe. Und 2. Wenn ich eine Plugin-Jar habe und sie in den Plugins-Ordner lege, funktioniert es bei manchen Plugins nicht wie z.b.: JumpDown mit dem Grund: Unsuportet Major Minor Version 51.0 und es bildet sich kein Ordner. Kann mir wer Helfen? Danke im Vorraus LG Nicolas

Antwort
von yam1811, 30

Wie hast du das fett gemacht ? Und ich glaube bei OSX sollte es was anderes sein, da OSX auf sicherheir legt und es dadurch schwierig wird mir Hamachi zu arbeiten :-)

Kommentar von Nivaum ,

in dem ich das wort  mit 2 ** umklammert habe. und wie soll ich mir sonst einen Spigot server kostenlos erstellen?

Kommentar von Nivaum ,

hab ich ja gemacht aber die ip geht ja bei freunden nicht

Kommentar von Myzzel ,

Man kann kostenlos Server erstellen, such auf YouTube nach "HimGames-Kostenloser Minecraft-Server"

Kommentar von yam1811 ,

Die kostenlose Variante ist *immer* "dumm". Aber es gibt auch günstige Server zu kaufen z.B. Host-unlimited

Kommentar von yam1811 ,

**…**

Kommentar von yam1811 ,

Hast du einen Server gekauft ?

Kommentar von Nivaum ,

nein. So einen mit Ordner auf dem Desktop. Kann mir wer sonst seinen Server-Ordner zum download, oder zu mindstens den Pluginordner mit Minigame swie Jump-Down, Enderwar oder so

Kommentar von yam1811 ,

Du musst mal schauen wir Hamachi bei OSX funktioniert, da Apple mehr auf Sicherheit legt wird es bisschen anders sein wie bei Windows

Wenn Plugins nicht funktionieren dann hast du eins von denen falsch gemacht:
- falsche Version
- hast du VAULT drauf?
- wichtiges Zusatz Plugin vergessen

Kommentar von Nivaum ,

Ich habe immer die neuste Version von den Plugins, aber ich habe Vault drauf. Außerdem habe ich mehrmals ein Update von Java6 auf Java 8 versucht. Nach der Instalation standt auf der Java-Website das alles funktioniert hat. Allerdings hat sich in der Java Datei auf dem Computer kein neuer Ordner gebildet. Da ist nur noch der von Java 6. Kann mir vielleicht da einer helfen, weil auf anderen Websiten steht, das es auch an der Java Version liegen kann.

Kommentar von Nivaum ,

Hier die Config:

[11:53:00 ERROR]: Could not load 'plugins/buildinggame-1.8.jar' in folder 'plugins'
org.bukkit.plugin.InvalidPluginException: java.lang.UnsupportedClassVersionError: com/gmail/stefvanschiedev/buildinggame/Main : Unsupported major.minor version 51.0
at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.java:135) ~[spigot_server.jar:git-Spigot-db6de12-18fbb24]
at org.bukkit.plugin.SimplePluginManager.loadPlugin(SimplePluginManager.java:329) ~[spigot_server.jar:git-Spigot-db6de12-18fbb24]
at org.bukkit.plugin.SimplePluginManager.loadPlugins(SimplePluginManager.java:251) [spigot_server.jar:git-Spigot-db6de12-18fbb24]
at org.bukkit.craftbukkit.v1_8_R3.CraftServer.loadPlugins(CraftServer.java:292) [spigot_server.jar:git-Spigot-db6de12-18fbb24]
at net.minecraft.server.v1_8_R3.DedicatedServer.init(DedicatedServer.java:198) [spigot_server.jar:git-Spigot-db6de12-18fbb24]
at net.minecraft.server.v1_8_R3.MinecraftServer.run(MinecraftServer.java:525) [spigot_server.jar:git-Spigot-db6de12-18fbb24]
at java.lang.Thread.run(Thread.java:695) [?:1.6.0_65]
Caused by: java.lang.UnsupportedClassVersionError: com/gmail/stefvanschiedev/buildinggame/Main : Unsupported major.minor version 51.0
at java.lang.ClassLoader.defineClass1(Native Method) ~[?:1.6.0_65]
at java.lang.ClassLoader.defineClassCond(ClassLoader.java:637) ~[?:1.6.0_65]
at java.lang.ClassLoader.defineClass(ClassLoader.java:621) ~[?:1.6.0_65]
at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:141) ~[?:1.6.0_65]
at java.net.URLClassLoader.defineClass(URLClassLoader.java:283) ~[?:1.6.0_65]
at java.net.URLClassLoader.access$000(URLClassLoader.java:58) ~[?:1.6.0_65]
at java.net.URLClassLoader$1.run(URLClassLoader.java:197) ~[?:1.6.0_65]
at java.security.AccessController.doPrivileged(Native Method) ~[?:1.6.0_65]
at java.net.URLClassLoader.findClass(URLClassLoader.java:190) ~[?:1.6.0_65]
at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:101) ~[spigot_server.jar:git-Spigot-db6de12-18fbb24]
at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:86) ~[spigot_server.jar:git-Spigot-db6de12-18fbb24]
at java.lang.ClassLoader.loadClass(ClassLoader.java:306) ~[?:1.6.0_65]
at java.lang.ClassLoader.loadClass(ClassLoader.java:247) ~[?:1.6.0_65]
at java.lang.Class.forName0(Native Method) ~[?:1.6.0_65]
at java.lang.Class.forName(Class.java:249) ~[?:1.6.0_65]
at org.bukkit.plugin.java.PluginClassLoader.(PluginClassLoader.java:64) ~[spigot_server.jar:git-Spigot-db6de12-18fbb24]
at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.java:131) ~[spigot_server.jar:git-Spigot-db6de12-18fbb24]
... 6 more


Kann mir wer helfen?

Kommentar von yam1811 ,

Falsche Version von buildinggame -.-

Kommentar von Nivaum ,

DAs ist die neuste version. Trotzdem danke für die antworten. Ich versuche es jetzt zu deinstallieren und dann zu installieren.

Kommentar von yam1811 ,

Java 6 deinstaliert?
Neuste Java 8 Version?
OSX ist für OFFICE PC's ideal aber für Gaming PC's würde ich Windoes empfehlen, weil dort kann man mehr für Gaming machen

Kommentar von Nivaum ,

Java 6 deinstaliert?
Neuste Java 8 Version?

Ja ich habe Java 8 Update 77 aber es wir vom Finder nicht erkannt. Von den Systemeinstellungen jedoch schon.

Antwort
von Nivaum, 5

Hat mit Java 8 jetzt bei fast allen (außer SkywarsReloaded) funktioniert! VIELEN DAN KAN ALLE!

Keine passende Antwort gefunden?

Fragen Sie die Community