Frage von HeikoWeberling, 49

Frage zu Wenn-dann-Funktionen bei Excel?

Hallo zusammen,

ich habe eine Frage zu Excel. Folgende Situation: Ich habe eine Teilnehmerliste. Es konnten sich immer Gruppen anmelden. Die Anzahl der Gruppenmitglieder variiert. Folgende relevante Daten habe ich:

Spalte B: Anzahl Mitglieder

Spalte C: gewünschter Workshop

Ich möchte nun herausfinden, wie viele Personen an Workshop A, B, C etc. teilnehmen wollen. Über "=countifs(c2:c300;"A")" könnte ich zwar herausfinden, wie viele Teams sich für Workshop A angemeldet haben usw., aber ich weiß dann noch nicht, wie viele Personen das dann tatsächlich sind. Man müsste also irgendwie noch die Spalte C hereinbringen. Sprich:

Wenn C2=A dann addiere B2. Und das ganze dann natürlich für die ganze Spalte. Ist wahrscheinlich ganz einfach, aber ich kriege es nicht hin.

Vielen Dank für Eure Hilfe im Voraus!

Schöne Grüße Heiko

Hilfreichste Antwort - ausgezeichnet vom Fragesteller
von Distel35, 33

Hallo Heiko, 

das Schlüsselwort für dein Problem lautet "SUMMENPRODUKT(...)".

Schau mal da (Beispiel mit den blauen Bällen ganz unten): 

https://www.lecturio.de/magazin/summenprodukt-in-excel/

Gruß Distel

Kommentar von HeikoWeberling ,

Super! Hab vielen Dank. Jetzt klappt es.

Kommentar von Oubyi ,

SUMMENPRODUKT - SUMPRODUCT - ist eine mächtige Funktion, mit der man viele Problemen lösen kann, so auch dieses.
Für diese Problemstellung gibt es aber auch eine spezielle Funktion, nämlich:
SUMMEWENN - SUMIF.
Nur mal zur Ergänzung.

Antwort
von Sven8219, 21

Bastel dir dazu eine Art Eingabemaske:

Nimm irgend eine Zelle und schreibe darüber "Workshop". Daneben "Teilnehmer gesamt". In die Zelle unter "Telnehmer gesamt" tippst (oder kopierst) du folgende Formel:

=WENN(D6<>"";SUMMENPRODUKT((C:C=D6)*(B:B));"")

Schreib nun in die Zelle unter "Workshop" deinen Workshop und daneben wird die die Anzahl angezeigt.

Erläuterung:

WENN(D6<>""

  • D6 war meine Zelle unter "Workshop". Dort wird also der Worksop eingetragen. WENN <> besagt nur, das wenn kein Wert in dieser Zelle ist dann...

SUMMENPRODUKT((C:C=D6)*(B:B))

  • Jetzt wird gesucht und zwar nach dem Wort in (bei mir) D6 in der kompletten Spalte C. In B wird dann die entprechende Anzahl herausgezgen

;"")

  • Hat noch mit der WENN Funktion zu tun. denn wenn nichts in (bei mir) D6 steht wird "" angezeigt. Also nichts :)

Hoffe das hilft

Kommentar von HeikoWeberling ,

Danke Dir! Ich bin bereits mit dem anderen Hinweis an mein Ziel gekommen, werde mir Deinen Weg, der ein wenig anders ist, aber auch noch mal ansehen. Vielen Dank!

Expertenantwort
von Oubyi, Community-Experte für Excel, 12

Das machst Du mit der englischen Funktion:

SUMIF()

Erklärt zum Beispiel hier:
http://www.techonthenet.com/excel/formulas/sumif.php

Keine passende Antwort gefunden?

Fragen Sie die Community