Frage von GeorgGermany, 23

Frage zu SVERWEIS?

Ich möchte in der funktionierenden Formel ...

=SVERWEIS($A121;INDIREKT("'"&INDEX({"6985"};VERGLEICH(1;(ZÄHLENWENN(INDIREKT("'"&{"6985"}&"'!A:A");$A121)>0)+0;0))&"'!A:C");3;0)?

{"6985"} gegen Zellbezug B1 tauschen, das ist der Tabellenblattname den ich in B1 austauschbar gestalten möchte.

Habe schon einiges probiert....mag nicht so recht gelingen.

Danke !

Expertenantwort
von Oubyi, Community-Experte für Excel, 18

Ich verstehe den Sinn der Matrixklammern in Deiner Formel nicht.
(Ich habe mich allerdings auch nicht intensiv mit dem Sinn der ganzen Formel beschäftigt, da mir das ohne Beispieltabelle schwer fällt)
Schau mal, ob sie nicht auch ohne klappt.
Dann sollte auch das funktionieren:

=SVERWEIS($A121;INDIREKT("'"&INDEX(B1;VERGLEICH(1;(ZÄHLENWENN(INDIREKT("'"&B1&"'!A:A");$A121)>0)+0;0))&"'!A:C");3;0)

Oder?

Kommentar von GeorgGermany ,

Hallo, nee...das hat leider #NV zur Folge. 

Kommentar von Oubyi ,

Dann hoffe ich, dass Dir Andere helfen können.
Ohne Beispieltabellen werde ich da nicht weiter 'rumprobieren.

Antwort
von Rubezahl2000, 23

Die zugehörige Tabelle kenne ich ja nicht, aber mein 1. Eindruck von deiner Formel ist, dass das "doppelt gemoppelt" ist.
Sowohl SVERWEIS als auch INDIREKT und INDEX, ist das wirklich erforderlich?
Normalerweise reicht eins von beiden, also entweder SVERWEIS oder die Kombi aus INDIREKT und INDEX.

Kommentar von GeorgGermany ,

Hey,

die Möörderformel war kopiert ;-) ....

mittlerweile ist mir das auch so gekommen, Danke für den Tip.

=SVERWEIS(A122;'6985'!A1:E412;3;WAHR) ist auch ok.

Aber die '6985' ... also der Verweis auf das Arbeitsblatt Namens 6985 soll mit B1 beschrieben werden..... und da klemmt es.

Kommentar von Oubyi ,

Dann so:

=SVERWEIS(A122;INDIREKT("'"&B1&"'!A1:E412");3;WAHR)

Kommentar von Rubezahl2000 ,

@GeorgGermany: Was passiert denn, wenn du in die Formel =SVERWEIS(A122;'6985'!A1:E412;3;WAHR) reingehst, den Teil  zwischen 1. und 2. Semikolon "'6985'!A1:E412" löschst und von da aus mit dem Cursor den gewünschten Tabellenbereich markierst und dann die Formel mit Return beendest ?

Ist die Tabelle B1 in der selben Arbeitsmappe wie die Tabelle mit der sverweis-Formel?

Antwort
von Ghanasoccer, 22

Ich würde den Namensmanager für diese zelle nutzen und dann dort einfügen.


Vielleicht kann man das so dann umgehen. Konnte es jetzt aber nicht ausprobieren...

Keine passende Antwort gefunden?

Fragen Sie die Community

Weitere Fragen mit Antworten