Frage von Williausphillie, 51

Frage zu Excel Nummerierung der Zeilen?

Hallo ich habe eine Tabelle erstellt.

Da steht abwechselnd ein Name und darunter ein Firmenname. Ganz Links möchte ich das nummerieren. Geht das nur Händisch, das ich alle zwei Zeilen eine Zahl rein schreibe oder gibt es einen Trick, der es Automatisiert, das jede zweite Zeile eine Zahl aufwärts ergibt?

Expertenantwort
von Suboptimierer, Community-Experte für Excel, 30

Beispiel Spalte B:

Name1
Firmenname1
Name2
Firmenname2
...
A1: =WENN(REST(ZEILE(A1);2)=1;(ZEILE(A1)+1)/2;"")

Die Formel herunter ziehen

Ich empfehle dir allerdings zu versuchen, pro Datensatz nicht mehr als eine Zeile zu opfern.

Kommentar von Oubyi ,

Diese Formel-Lösung ist natürlich richtig, aber ich denke, wenn die Aufgabe so einfach ist, wie beschrieben, ist die von @inkaddict beschriebene Vorgehensweise sinnvoller.

Kommentar von Suboptimierer ,

Richtig. So geht es auch.

In meiner Formel hätte ich mir den +1 Offset sparen können, wenn ich auf A2 mich bezogen hätte, fällt mir gerade noch auf.

Kommentar von Oubyi ,

Stimmt. Aber ich glaube das wäre mir auch passiert, weil man so daran gewöhnt ist Zählvariablen mit Zeile(A1) zu basteln.

Antwort
von inkaddict, 32

Hast du schon mal ausprobiert:

A1: 1

A2: leer

A3: 2

A4: leer

Dann von A1:A4 markieren und über den schwarzen Punkt unten rechts in der Markierung nach unten ziehen?

Kommentar von Iamiam ,

kann ich nur unterschreiben, bevor Du Formeln setzt, probiere das hier!

Antwort
von Nayes2020, 26

Du schreibst erstmal die 1

dann = Zelle drüber

dann = zelle Drüber 1 1

dann = Zelle drüber

dann = Zelle drüber + 1

das kannst du markieren und nach unten kopieren

also mit Zelle drüber meine ich nicht den Text Zelle drüber sondern eben den Namen der Zelle die drüber ist. C5 oder whatever

Kommentar von Iamiam ,


den Namen der Zelle die drüber ist. C5 oder whatever:

heißt Zelladresse

Name ist nämlich irreführend, da man nicht nur größeren Bereichen, sondern auch einzelnen Zellen einen (Bereichs-)NAMEN zuweisen kann. (=benannter Bereich)

Keine passende Antwort gefunden?

Fragen Sie die Community

Weitere Fragen mit Antworten