Frage von Marceloblau01, 79

Formel zum zählen von leeren Zellen bis zum nächsten Wert , hat da vielleicht jemand eine Lösung?

Hallo , ich möchte mit einer Formel leere Zellen bis zum nächsten Wert zählen. ist das möglich ?

Beispiel , D100 =1 ,

gesuchte Formel in D1001 , wie viele leere Zellen befinden sich zwischen D1000 und D100

das ist jetzt eine leichte Kopfrechnung aber das ist auch nur ein Beispiel,

gibt es dafür eine Formel die das für mich erledigen kann ? die Werte die in den Spalten auftauchen sind immer nur 1 oder sie sind leer!

Danke im voraus

Hilfreichste Antwort - ausgezeichnet vom Fragesteller
von Iamiam, Community-Experte für Excel, 42

beziehe Dich in Deiner Formel auf die letzte leere Zelle(sei D1000)

eine {Matrix}-Formel daneben liefert die Zeilenzahl der letzten gefüllten Zelle:

{=MAX((B$1:B1000<>"")*ZEILE(B$1:B1000))}

Das musst Du jetzt noch von der Zeile der Formel abziehen, also:

/=Zeile()-MAX((B$1:B1000<>"")*ZEILE(B$1:B1000))}

Achtung: Dies ist eine Matrixformel! Die geschweiften {Klammern} NICHT miteingeben, sondern die Formel anstatt mit einfachem Enter mit der Kombination (gleichzeitig) Strg+Shift+Enter abschließen (nach jeder Neubearbeitung wieder!). Die {Klammern} entstehen dann automatisch.

Schreibtechnisch nimmst Du am besten die rechte Strg- und Umschalttaste, dann gehts mit einer Hand und lässt sich auch leichter merken!  - - -

Du kannst die Formel auch in

D

1000 schreiben, dann mit Bezug auf D999:und -optional- einer leicht variierten Form:

{=ZELLE("Zeile";D999)-MAX((B$1:B999<>"")*ZEILE(B$1:B999))}

Zeile 999 jetzt deshalb, weil Zeile 10000 ja jetzt mit dieser Formel gefüllt ist und als Max angezeigt würde. Diese Formel kannst Du überall hinschreiben, musst nur zum Kopieren entsprechende $-Zeichen setzen.

Kommentar von Iamiam ,

So ein Mist! bei diesem Editor muss man sich jeden Tag auf neue Macken einstellen: Der Umbruch von D1000 war in der Vorschau nicht zu sehen!

Expertenantwort
von Ninombre, Community-Experte für Excel, 44

Das Rückwärtszählen in Excel ist nicht so einfach (vom Erfinder wohl nicht vorgesehen...). Du musst die letzte Zeile für meinen Ansatz klar bestimmen können, also D1000 oder ähnliches.

Hilfsspalte, z.B. E ab E100:

=WENN(ZÄHLENWENN(D$100:D100;1)<=ZÄHLENWENN(D$100:D$1000;1);"";1)

Die Formel runterkopieren bis D1000
in E1001: =summe(E100:E1000)-1
ergibt die leeren Zellen zwischen der letzten 1 und D1000. Meine Annahme ist allerdings, dass in D1000 KEINE 1 steht. Wenn das der Fall sein sollte:

=WENN(ZÄHLENWENN(D$100:D100;1)<=ZÄHLENWENN(D$100:D$1000;1)-1;"";1)

Expertenantwort
von DeeDee07, Community-Experte für Excel, 50
Kommentar von Marceloblau01 ,

sorry vielleicht falsch ausgedrückt es soll bedeuten , von D1000 soll nicht , bis Angabe D100 gezählt werden sondern bis zum nächsten Wert 1 , also D:D die Formel in D1001, und gesucht wird die Anzahl der leeren Zellen rückwärts bis der Wert 1 erscheint , der erste Wert 1.

Keine passende Antwort gefunden?

Fragen Sie die Community

Weitere Fragen mit Antworten