Frage von areck, 52

Formel für wenn bei Excel? ?

Hallo, möchte eine abrechnungstabelle erstellen die verschiedene währungen beinhaltet, soll letztendlich alles in Euro umgerechnet werden. brauch dazu die formel um die automatische zuordnug der zelle mit dem richtigen umrechnungsfaktor zu bestimmen. zb. wenn f13 NIO dann g13/d7, wenn f13 USD dann g13/d6, wenn f13 PGK dann g13/d8,.... siehe Foto, Danke

Expertenantwort
von Oubyi, Community-Experte für Excel, 25

Diese Formel in I13 und runterkopieren:

=G13/INDEX($D$4:$D$8;VERGLEICH(F13;$C$4:$C$8;0))

Klappt es?

Kommentar von Iamiam ,

Man sieht hier mal wieder, wie notwendig Leute wie Du sind, bei soviel im wahrsten Sinn des Wortes hilflosen Antworten!

Kommentar von Oubyi ,

Danke,
aber das hätte wohl jeder "von uns" hier so "aus dem Ärmel geschüttelt".
Da war ich diese mal nur der schnellste.

Kommentar von areck ,

vielen dank für die formel, funktioniert super. jedoch habe ich das problem das in den leeren zellen darunter (wo die formel reinkopiert ist für zukünftige einträge) ein fehler gezeigt wird und somit die endsumme am schluss der tabelle nicht berechnet werden kann.

hast dafür auch noch eine lösung, wäre dir sehr dankbar!

Kommentar von Oubyi ,

Verstehe ich Dich richtig, Du willst nur verhindern, dass der Fehler ANGEZEIGT wird (und die SUMME() klappt)? Dann so:

=WENNFEHLER(G13/INDEX($D$4:$D$8;VERGLEICH(F13;$C$4:$C$8;0));"")

Kommentar von areck ,

klappt leider nicht so!

möchte den fehler ignorieren damit die summe klappt.

oder die formel so gestalten damit nicht zwangsläufig ein fehler entsteht wenn keine werte eingetragen.

noch eine idee?

danke im voraus

Kommentar von Oubyi ,

Dann solltest Du vielleicht "Klappt nicht so" etwas genauer beschreiben. Mit der obigen Formel KANN kein Fehler mehr angezeigt werden und die SUMME()-Funktion sollte auch funktionieren.
Als WAS genau "klappt nicht"

P.S.: Muss jetzt zur Arbeit, schau morgen früh wieder 'rein.

Kommentar von areck ,

Klappt so!!!!

sorry, fehler war meinerseits.

vielen dank für die hilfe!

Kommentar von Oubyi ,

Gern geschehen ☼
Freut mich, dass ich helfen konnte.

Antwort
von Tron1701, 1

Hallo,

bei deinem Beispiel war folgender Fehler "wenn f13 USD dann g13/d6"

Dies wäre meine Lösung:

=WENN(F13="";"";WENN(F13=$C$4;G13/$D$4;WENN(F13=$C$5;G13/$D$5;WENN(F13=$C$6;G13/$D$6;WENN(F13=$C$7;G13/$D$7;WENN(F13=$C$8;G13/$D$8;""))))))

Formel zusammenhängend schreiben oder Formeltext markieren und in deiner Tabelle, beginnend in Zeile 13 einfügen und nach unten kopieren.

(Durch die 1. "WENN" Abfrage erscheint #DIV/0! nicht mehr !)

oder so:

=WENN(F13="";"";WENN(F13="EUR";G13/$D$4;WENN(F13="USD";G13/$D$5;WENN(F13="LAK";G13/$D$6;WENN(F13="NIO";G13/$D$7;WENN(F13="PGK";G13/$D$8;"")))))

Gruß Tron

Antwort
von Grautvornix, 31

Das geht über Funktion, logische WENN Verknüpfung, kenne ich aber nur genaue Eingabe bei Open Office. Es können bis zu 26 Bedingungen sein.

Geht aber ähnlich, einfach mal Funktionen aufrufen.

Antwort
von Glyxo, 29

=WENN(A1="xx";dann;sonst)

Kommentar von Glyxo ,

in die sonst Spalte fängst du einfach wieder an mit wenn... also so... =wenn(a1="nio";a2/a3;wenn(b1="usd";b2/b3;wenn(... ...))) es kann sein dass du die"" draußen lassen musst... da bin ich mir jetzt nicht sicher. zum Schluss wenn kein sonst Befehl gebraucht wird, machst du "" für leer lassen... oder "0" für 0

Kommentar von Glyxo ,

denke immer... die Funktion ist wenn... also =WENN(wenn;dann;sonst) ich hoffe du verstehst was ich meine xD

Keine passende Antwort gefunden?

Fragen Sie die Community

Weitere Fragen mit Antworten