Frage von heiko401, 20

Formel für Calc mit Änderung der Formatierung?

Hallo,

folgendes Szenario: Spalte A [GÜLTIGKEIT] im Datumsformat TT.MM.JJJJ; Spalte B [STATUS]

Ich möchte den Ablauf einer bestimmten Sache angezeigt bekommen. Wenn das Datum in Spalte A im Jahr 2016 ist und wir auch das Jahr 2016 haben, soll in Spalte B stehen "läuft dieses Jahr ab" in rot stehen. Wenn das Datum in Spalte A z.B. 2015 ist und wir haben 2016 soll da stehen "abgelaufen" (auch in rot).

Würde das mit den Formeln WENN und JAHR versuchen, da ich das aktuelle Jahr nicht immer manuell eingeben möchte. Gibt es da einen Lösungsvorschlag?

PS: ist keine Hausaufgabe, sondern wird die Lizenztabelle für einen Sportverein ;) also nicht vorzeitig löschen!

Expertenantwort
von Ninombre, Community-Experte für Excel, 8

ich kann die Formel nur für Excel überprüfen, nicht für calc

=wenn(jahr(a1)=jahr(heute());"läuft dieses Jahr ab";wenn(jahr(a1)<jahr(heute());"ist abgelaufen";""))

Hinsichtlich der Schriftfarbe wäre in Excel noch eine bedingte Formatierung notwendig, die auf den Zellinhalt "nicht leer" also <>"" o.ä. abfragt.

Kommentar von Iamiam ,

die einfachen (alten und deshalb nicht Namens-geschützten) Formeln sind oin Libre Office die gleichen, solange keine Wildcards oder Blatt-externen Adressen drinstehen (wird beides dort etwas anders formuliert, ebenso wie die bedingte Formatierung, die aber ebenso möglich ist, in manchen Kombinationen macht auch noch A:A oder 1:1 Schwierigkeiten, daran arbeiten sie anscheinend noch. OO ist dagegen "abgehängt")

Antwort
von PWolff, 10

Die Funktion HEUTE() liefert das aktuelle Datum zurück.

Damit ist das aktuelle Jahr JAHR(HEUTE()).

Antwort
von AnonYmus19941, 8

OK, GF funktioniert gerade nicht, ich probiere, die Formel in die Kommentare zu stellen.

Kommentar von AnonYmus19941 ,

Tja, einfügen geht offenbar nicht ...

Dann eben über pastebin: http://pastebin.com/rxY91rqn

Das ist die Formel für Zelle B1. Du kannst noch die bedingte Formatierung verwenden, um den Text rot zu färben, wenn er bald abläuft. Sag Bescheid, falls du Hilfe brauchst.

Kommentar von Iamiam ,

vermutlich hast du in Deiner Formel ein < stehen, das verhindert das Einfügen. Ausserdem geht das nicht von einer xl-Textfeld-Textkopie, die müsstest Du erst in eine Zelle einfügen und dann erst wieder als Text kopieren- so meine Erfahrungen zum Thema einfügen.

Ich ersetze immer ganz pragmatisch das/die < durch ◄ (übersieht man nicht und egal ob xl Fehler meldet) und korrigiere das dann hier manuell zurück zu <, dann gehts. Sheisz Editor hier! (immer noch, trotz der vielen Verschlimmbesserungen in jüngster Vergangenheit!

Kommentar von AnonYmus19941 ,

Oh, ja, dann geht es. Danke :-)

=WENN(JAHR(A2)<JAHR(JETZT());"abgelaufen";WENN(JAHR(A2)=JAHR(JETZT());"laeuft ab";"OK"))

Keine passende Antwort gefunden?

Fragen Sie die Community

Weitere Fragen mit Antworten