Frage von Schrotti2002, 85

Fehlermeldung bei IPv6-Modprobe?

Hi Community,

ich hatte schon länger vor einen Mailserver einzurichten, und konnte mich heute auch mal endlich dazu bewegen es zu tun ;-)
Nun aber das Problem: Ich habe vor den Mailserver unter der Plattform citadel laufen zu lassen und gelangte nun zum Schritt mit der IPv6-Modprobe. Beim durchführen hierbei bekam ich diese Fehlermeldung:
modprobe: ERROR: ../libkmod/libkmod.c:557 kmod_search_moddep()  could not open moddep file '/lib/modules/4.1.13-v7+/modules.dep.bin'

Meine Frage: Was genau bedeutet das und wie kann ich den Fehler fixen?

Hoffe Ihr könnt mir helfen,
Euer Schrotti!

Antwort
von thomasschaefer, 62

Deine Kernelkonfiguration ist kaputt. Unabhängig davon ob ipv6 als Modul vorliegt oder doch schon fester Bestandteil des Kernels ist - modeprobe sollte keine solchen Fehlermeldungen erzeugen.


Installiere die Kernelpakete erneut.

Kommentar von Schrotti2002 ,

Allerdings sind im "fehlerhaften" Verzeichnis noch andere ähnlich klingende Ordner hinterlegt:

pi@raspberrypi:~ $ modprobe ipv6
modprobe: ERROR: ../libkmod/libkmod.c:557 kmod_search_moddep() could not open moddep file '/lib/modules/4.1.13-v7+/modules.dep.bin'
pi@raspberrypi:~ $ cd /lib/modules
pi@raspberrypi:/lib/modules $ ls
4.1.19+  4.1.19-v7+
pi@raspberrypi:/lib/modules $

Kommentar von thomasschaefer ,

Ich habe auch einen raspberry pi.

Bei mir kommt bei

uname -a

das gleiche raus wie wie bei

ls /lib/modules

nämlich: 4.1.19 ....

Bei Dir sucht ein Kernel mit Version 4.1.13 nach seinen Modulen und findet keine, weil die nur für 4.1.19 vorliegen.

Deine Konfiguration ist im Eimer.

Keine passende Antwort gefunden?

Fragen Sie die Community