Frage von Lolsegame, 53

Exel Formel ?

Hallo

Ich bräuchte Hilfe bei exel Nämlich ich möchte die Tabelle so das wenn in der Zelle B1 ein Text steht das dann in der Zelle A1 steht um wieviel Uhr in die Zelle B1 etwas eingetragen wurde?

Hilfreichste Antwort - ausgezeichnet vom Fragesteller
von Ninombre, Community-Experte für Excel, 15

mit Formeln kannst Du keinen dauerhaften Zeitstempel einfügen, die Funktion jetzt, heute etc. werden laufend aktualisiert.

Soll wirklich nur die Zelle B1 überwacht werden oder ein Teil der Spalte B? In meinem Beispiel würde B1 bis B10 geprüft und in der jeweilen Zeile in Spalte A die aktuelle Uhrzeit hinterlegt

Private Sub Worksheet_Change(ByVal Target As Range)
If Not Intersect(Target, Range("B1:B10")) Is Nothing Then
Target.Offset(0, -1).Value = Now()
End If
End Sub

Diesen Code zum Tabellenblatt hinterlegen, das überwacht werden soll, s. Bild - da ist es bei mir halt Tabelle7

Wenn Du den Ribbon Entwicklertools nicht siehst, ist hier beschrieben, wie man ihn einblenden kann: https://support.office.com/de-de/article/Erstellen-oder-L%C3%B6schen-eines-Makro...
Wenn der Ribbon da ist, auch Visual Basic, dann siehst Du auch das Menü wie in meinem Bild.

Beim Speichern der Datei muss dann als Dateityp xlsm ausgewählt werden, damit das Makro auch mitgespeichert wird. Beim üblichen Typ xlsx wird das Makro nicht übernommen.

In Kurzform was das Makro tut: worksheet_change wird, wie der Name schon nahelegt, bei jeder Änderung auf dem Tabellenblatt aufgerufen. Da nur Änderungen in Spalte B1:B10 betrachtet werden sollen, wird das in der 2. Zeile darauf eingeschränkt. Dort kannst Du den Bereich auch anpassen, der überwacht werden soll.
Target.offset(0,-1) -> Target ist die geänderte Zelle. Offset ist eine Verschiebung um 0 Zeilen und eine Spalte zurück, sprich Spalte A in der gleichen Zeile wie die geänderte Zelle. Dort wird die aktuelle Zeit eingetragen.
Mehr soll ja nicht passieren.

Expertenantwort
von Iamiam, Community-Experte für Excel, 10

zwar nicht automatisch, aber sehr kurz: Sofort nach Eintrag auf A1 klicken und mit Strg+: (Colon) die Zeit setzen (bleibt fix).

Könntest aber auch den Text in B1 so einleiten: Strg+:, nochmals Doppelpunkt und Leer(nur der Form halber), dann Text eintippen. Hinterher steht dann in B1:

18:33: Text

Mit Datum: Strg+., dann Leer, dann Strg+: (nach : und leer) weiter im Text

Sind zwei extrem brauchbare und nicht allgemein bekannte Shortcuts! Gehen auch mitten im Text.

das zweite ist weniger Fehler-anfällig, da es mehr auffallt, wenn in einer Kolonne der Eintrag fehlt und der Text nach links rutscht!

Antwort
von pauwal, 48

Hallo, es geht nur mit Makros zum Aufzeichnen von Datum und Uhrzeit... Kennst du dich damit aus?

Kommentar von Lolsegame ,

Ne leider nicht 

Antwort
von iMPerFekTioN, 6

Versuchs mal so:

=WENN(B1="";"";WENN(ZELLE("TYPE";A1)="v";A1;JETZT()))

Sie kennen die Antwort?

Fragen Sie die Community

Weitere Fragen mit Antworten