Frage von KleineGottOhm, 33

Excelhilfe?

Hallo.

Ich habe mich hier mal zum Thema Stundennachweis durchgelesen. Aber die hier gegebenen Möglichkeiten erfüllen nicht ganz das was ich gerne hätte.

Ich möchte einen Stundennachweis erstellen. Soweit habe ich alle Einstellungen vorgenommen (ausblenden von Tagen die der Monat nicht hat, vekettungen zum Jahr und Monat usw.). Jetzt geht es an die Errechnung der Stunden. Ich habe mir aus meiner Lehre von meiner Kollegin folgende Formel mitnehmen dürfen

=WENN(E10<D10;1-D10+E10:E10;E10-D10)*24

Klappt super. Sie tut das, was ich möchte. ABER: Ich arbeite ja nicht immer die die vollen Stunden durch von 12-13.30 ist Mittag. Also habe ich einfach ein -1,5 dazu gemacht. Klappt auch. Ich muss aber auch Samstags von 8-13 Uhr, dann mach ich keine Pause oder ich muss nur Vormittags oder mal Nachmittags.

Dann rechnet Excel mir ja immer 1,5 Stunden runter. Klar mach ich auch mal mehr Stunden als gewollt, aber das ist nicht das Problem, da die Formel das ja mit einrechnet.

Ich habe Im Schnitt 6 verschiedene Arbeitszeiten. Das habe ich dann mit ner Wenn(oder( versucht. Mein letzter Ausgang ist dann "" . Dann leert der mir aber alles.

Hier die Formel mit den Zeiten (Spalte D steht die Anfangszeit, Spalte E die Endzeit)

=WENN(ODER(E10=12);3;WENN(ODER(E10=13);5;WENN(ODER(E10="15:30");5;WENN(ODER(E10=16);5,5;WENN(ODER(E10=18);7,5;WENN(ODER(E10=19);8,5;""))))))

Demnach frage ich mich, wo mein Fehler liegt? Ich habe sogar schon über ein Arbeitsblatt nachgedacht mit den Stunden und dann mit dem S-Verweis zu arbeiten.

Ich Möchte auf keinen Fall mit der Funktion Spaltenausblenden arbeiten.

Vielen Dank für die Hilfe vorab.

Hilfreichste Antwort - ausgezeichnet vom Fragesteller
von Suboptimierer, Community-Experte für Excel, 18

Ich weiß nicht, ob ich damit alles erschlage, aber die Formel deiner Kollegin kann man optimieren, da E10:E10 das Gleiche ist wie E10.

In deiner Formel schlägt wahrscheinlich E10="15:30" fehl. Probier es mal aus. Schreibe in eine Zelle (Bsp. A1) 15:30 und in eine andere die Formel =A1="15:30". Besser: =A1=15,5/24. 

ODER mit nur einer Bedingung ergibt keinen Sinn. Die ODERs kannst du entfernen.
Besser wäre es, wenn du den SVERWEIS verwenden würdest.

Bei ...WENN(ODER(E10=16);5,5;WENN... hat das WENN einen Parameter zuviel.

Kommentar von KleineGottOhm ,

Wie kommst du denn auf die 5/24? Das verstehe ich grade nicht ganz. Da rechnets mir leider nur in der Zelle das Richtige aus. Alle Anderen bleiben leer. Aber ein Stück weiter bin ich alle mal jetzt.

Kommentar von Suboptimierer ,

Danke für den Stern.
________

15:30 Uhr = 15 Stunden + 1/2 Stunde = 15,5 Stunden.

1 Tag = 24 Stunden
x Tage = 15,5 Stunden

Dreisatz:

x = 15,5*1/24 = 15,5/24

Excel rechnet Zeiten auf Basis von Tagen.

Antwort
von Garfield0001, 21

Ich finde keinen Grund für ein "oder" da du immer nur eine sache in der wenn-Formel hast.
"Oder" muss aber mind. 2 Argumente prüfen (macht ja sonst auch keinen Sinn)

Antwort
von Seanna, 21

Das mit dem Stunden abziehen ist recht simpel... Pause nur abziehen wenn Arbeitszeit größer 6h.

Den Rest unten verstehe ich mangels Zusammenhang nicht.

Kommentar von KleineGottOhm ,

Danke. Auf die einfachste Lösung bin ich nicht gekommen.*G*

Keine passende Antwort gefunden?

Fragen Sie die Community

Weitere Fragen mit Antworten