Frage von Roach720, 53

Excel Zeitabhängigkeit und Verfall?

Hallo liebe Community,

ich stehe vor einem großen Problem. Es geht bei Excel um Folgendes:

Ich habe mehrere Spalten mit verschiedensten Werten, wobei die meisten aufeinander aufbauen und fortlaufend sind. Im groben, Zinseszins, aber ohne die Zinsformeln.

Ich muss:

bestimmte Zahlen, die vor x Tagen addiert wurden, müssen nach diesen x Tagen verfallen. Z.B. Ich kaufe heute ein Gutschein im Wert von 10 Euro welcher 180 Tage lang gültig ist. Dabei kaufe ich täglich neue, von Zeit zu Zeit immer mehr. Nun sind 180 Tage rum und der erste muss raus fallen da seine Gültigkeit abgelaufen ist. Dieser Gutschein darf nicht mehr mitzählen. Das Problem dabei stellt sich mir, dass die 180 Tage variabel sind, da diese Zahl berechnet wird aus anderen Zellen.

Wie bekomme ich das am besten hin?

Vielen Dank schon mal für die Hilfe

LG Roach720

P.S.: wenn etwas unklar ist, einfach fragen;)

Expertenantwort
von Suboptimierer, Community-Experte für Excel & Mathematik, 40

Mit verbundenen Augen geschossen: 

Mit SUMMEWENN kannst du als Bedingung die Zelle angeben, in der berechnet wurde, ob der Wert noch gültig ist.

Kommentar von Roach720 ,

vielen dank für die schnelle antwort.
okey soweit so gut. doch bin ich in der hinsicht ein noob. ist es möglich, dass du du mir kurz aufzeigst, wie ich das zu schreiben habe...mein problem liegt wiegsagt darin, dass die 180 Tage variabel sind und ich damit kein direkten Zellbezug herstellen kann oder auch kein Bereich definieren kann. oder bin ich da falsch? Wenn ja, wo hab ich meinen Denkfehler?

Kommentar von Suboptimierer ,

=SUMMEWENN(<Bereich mit Zellen, in denen die verbleibende Haltbarkeit pro Zeile berechnet wird>;">0";<benachbarte Wertespalte, über die bei Erfüllung der Kriterien summiert werden soll>)

Du kannst auch andere Rechenoperationen als nur zu summieren durchführen. Flexibler ist da die Funktion SUMMENPRODUKT.

Kommentar von Roach720 ,

okey danke dir:)

ich stell mich wahrscheinlich einfach zu blöd an. Bzw. Ich sehe den Wald vor lauter Bäumen nicht mehr...

Ich habe keine Ahnung was du damit meinst. 

=SUMMEWENN("die Zelle, wo beschrieben wird, wie viel Tage die Gültigkeit ist";" ">0" "; "check` ich nicht")

tut mir leid:/ aber es währe wunderbar, wenn du das doch vlt. ein bisschen ausführlicher schreiben könntest.

Kommentar von Ninombre ,

Wie ermittelst Du denn die Frist, wenn sie in keiner Zelle direkt abgelegt ist bzw. warum machst Du das nicht so? Es muss ja eine bestimmte Berechnungslogik für die 180 Tage geben. Die könnte man irgendwo in einer Zelle hinterlegen und dann abfragen.

=SUMMEWENN(A1:A5;">"&HEUTE()-ZUFALLSBEREICH(1;180);C1:C5)

Hier steht ein Datum in A, der zu summierende Wert in C

Das fettgedruckte kannst Du durch eine konkrete Zelle oder eine sonstige Berechnungslogik ersetzen.

Kommentar von Roach720 ,

Hallo Ninombre,

um genau zu sein sind es 180,18. Berechnen tue ich diese wie folgt:

Ich habe zwei Werte, einmal 0,0666 und der andere ist 12. Beides Euro-Währung. die 0,0666 gibt es am Tag, die 12,-€ ist das Gesamtergebnis. D.h. wie viel Tage werden benötigt um mit 0,0666€ 12€ voll zubekommen. Antwort: 12...Nun ist die Herausforderung:

Wenn die 0,0666 variabel sind ist auch die 180 variabel. Weiter heißt das, wenn die 12€ erreicht sind, fällt (Beispielhaft der Gutschein) der Gutschein raus und wird nicht mehr gezählt...

Somit darf er in der Tabelle nicht mehr gewertet werden. Und das möchte ich reinbringen.

Da irgendeine Hilfestellung?

Danke dir;)

Expertenantwort
von Oubyi, Community-Experte für Excel, 15

Ich setzte mal neu an, weil für mich das alles immer verwirrender wird.
Ich versuche das mal auf ein einfaches Szenario 'runterzubrechen mit Deinem Gutschein-Beispiel:
Du hast in A1:A100 Beträge stehen.
In B1:B100 stehen die Datümer, an denen diese "bereitgestellt" wurden.
In C1:C100 steht die Anzahl Tage, die sie gültig sein sollen (die müsstest Du ja irgendwie berechnen können).
Diese Formel zeigt Dir jetzt die Summe aller Beträge an, deren Gültigkeit heute! noch nicht abgelaufen ist:

=SUMMENPRODUKT((A1:A10)*((B1:B10+C1:C10)>HEUTE()))

Vielleicht kannst Du an diesem Beispiel einfach erklären, was nicht passt, was in Deinem Szenario also anders ist.

Keine passende Antwort gefunden?

Fragen Sie die Community