Frage von QuestionMastero, 63

Excel: Wie kann ich den Inhalt einer Zelle in einer Funktion verwenden?

Microsoft Excel; Ich habe vereinfacht gesagt folgendes Problem:

Ich habe eine große Tabelle mit angenommen 100 Zeilen und 1 Spalte. Also sind die Zellen A1 bis A100 mit Zahlenwerten belegt.

Wenn ich nun den Mittelwert dieser Zahlen bestimmen möchte, nutze ich dafür die Funktion =MITTELWERT(A1:A100). Das funktioniert einwandfrei.

Nun habe ich noch eine weitere Zelle B1 mit dem Zahlenwert 32; Jetzt möchte ich den Mittelwert der Zahlen von A1 bis zur Zeile mit dem Wert in der Zelle B1 bestimmen, so nach dem Motto =MITTELWERT(A1:A(B1)), also im Beispiel =MITTELWERT(A1:A32); So funktioniert es aber nicht. Ich hab auch schon länger gegoogelt, wie ich den Wert einer Zelle verwenden kann, aber nichts gefunden, was mir weiterhelfen könnte, den Wert als Zieladresse zu verwenden…

Danke schonmal für eure Hilfe!!!

Expertenantwort
von Iamiam, Community-Experte für Excel, 40

=Mittelwert(indirekt("A1:A"&Vergleich(B1;A1:A100;0)))

oder, wenn Du den Mittelwert zwischen zwei GrenzZellen mit ihren Werten in B1 und B2 suchst,

=Mittelwert(indirekt("A"&Vergleich(B1;A1:A100;0)&":A"&Vergleich(B2;A1:A100;0)))

Das ist aber nicht zu verwechseln mit der Mittelwertbildung der Werte zwischen zwei Grenzen, die nicht von vornherein lokalisiert sind:

=(Summewenn(A1:A100;"<B2";A1:A100)-Summewenn(A1:A100;"<B1";A1:A100))/
(Zählenwenn(A1:A100;"<B2";A1:A100)-Zählenwenn(A1:A100;"<B1";A1:A100))

ich glaube, es gibt neuerdings auch Mittelwertwenn(), da habe ich aber keine Erfahrung für 2 Bedingungen.

Kommentar von DeeDee07 ,

Interessant, wie eine Frage unterschiedlich interpretiert werden kann. Intuitiv (durch die Formel und den Screenshot in der Frage) hätte ich es wie Jackie gelöst und denke, dass es auch so gefragt war.

Allerdings entspricht deine Lösung tatsächlich dem Teil in der Frage

von A1 bis zur Zeile mit dem Wert in der Zelle B1

Für bedingten Mittelwert mit mehr als einer Bedingung gibt es MITTELWERTWENNS.

Antwort
von Jackie251, 36

das machst du so

=MITTELWERT(INDIREKT("A1:A"&B1))

Keine passende Antwort gefunden?

Fragen Sie die Community