Frage von Falk7, 149

Excel: Wenn z.B. "Tanken" in einer Zelle eingetragen ist, soll der Wert der Nachbarzelle automatisch auch in die separate Spalte "Tanken" einkopiert werden?

Ich führe ein Kassenbuch, dass pro Buchung eine Zeile mit 3 Zellen (in Spalten sortiert) hat:

....A.............B...........C....

Datum / Betrag / Konto

01.01.15 / 15,00 € / Tanken

02.02.15 / 20,00 € / Material

03.01.15 / 10,00 € / Tanken

04.01.15 / 25,00 € / Spesen

Ich möchte gerne, dass, wenn in der jeweiligen Zelle der Spalte "Konto" z.B.: "Tanken" eingetragen ist, der dazugehörige Euro-Wert aus der Nachbarzell auch automatisch in eine neue separate Spalte "Tanken" kopiert wird. Und wenn in der Zelle aber "Material" stehen sollte, dass dieser Wert dann in eine separate Spalte "Material" kopiert wird. Also eine automatische Kopierung und Zuordnung der kopierten Werte in seprate Spalten. Ich hoffe, dass ich mich einigermaßen verständlich ausgedrückt habe und würde mich freuen, wenn mir jemand eine Lösung geben kann. Vielen Dank im Voraus Falk

Expertenantwort
von Suboptimierer, Community-Experte für Excel, 149

Ich gehe davon aus, dass du in deinen Untertabellen keine Lücken haben möchtest. Wenn die Reihenfolge verändert werden kann, kann ich spontan eine Lösung bieten: 

=KGRÖSSTE((C2:C10="Tanken")*B2:B10;ZEILE(1:10))

Das als Matrixformel mit Strg + Shift + Enter abschließen.

Antwort
von qwertzuh, 105

ich hoffe ich habe es richtig verstanden, aber ich würde den SVERWEIS nehmen.

da kannst du in einer Tabelle nach einem bestimmten Wort suchen und dir dann z.B. ein Wert aus einer anderen Spalte wiedergeben lassen.

Antwort
von Herb3472, 92

Spalte C:

=WENN($A1= "Tanken"; $B1;"")

Spalte D:

=WENN($A1 = "Material"; $B1;"")


usw. usw.

Kommentar von Herb3472 ,

Sorry, hab' mich mit den Spalten vertan

Spalte D:

=WENN($C1= "Tanken"; $B1;"")

Spalte E:

=WENN($C1 = "Material"; $B1;"")

Kommentar von Falk7 ,

Besten Dank Euch allen für die schnelle Antwort. Funktioniert! Gruß vom Falk

Antwort
von flewilo, 120

Hab mich auch mal daran versucht:

Es kommt letztlich darauf an wie deine Ausgabematrix aussehen soll. Eine der einfachen Varianten sieht so aus. (siehe Bild)
Problem hierbei ist, dass du jede Art von Konto extra aufgelistet hast, mit Lücken.
Allerdings trotzdem einfach und übersichtlich.

Entscheidende Formel hierfür ist diese:

"=WENN(Q23="Tanken";P23;0)"

Diese passt du dann pro Spalte natürlich an das Konto an ;)

Hoffe das hilft.

Antwort
von Ortogonn, 69

Hallo Falk,

etwas abseits deiner Frage empfehle ich beim Thema Kassenbuch gern, auch einmal einen Blick auf das Programm MyMicroBalance zu werfen.

http://www.mymicrobalance.com/

Es gibt eine kostenlose Version.

Keine passende Antwort gefunden?

Fragen Sie die Community

Weitere Fragen mit Antworten