Frage von Hayla88, 52

Excel wenn und Befehle Verknüpfen?

Excel wenn und Befehle Verknüpfen?

Hallo liebe Community,

Ich muss eine lange Namensliste schnellstens zusammenstellen in Excel und ich habe schon gesehen, dass da sehr viele Doppelte Einträge vorkommen.

Wie kann ich nun eine Formel bauen (Bitte kein makro), mit der ich folgendes erreiche:

also die Daten umfassen z.B. Spalten A bis D (Vorname, Zuname, Firma, Titel)

Ich will nun, dass in Spalte E jeweils immer dann der text "DOPPELT" neben jeder befüllten Zeile erscheint, WENN der Vorname, der in entsprechender Zeile in Spalte A steht, mehr als ein mal in gesamte A-Spalte vorkommt UND WENN auch der zugehörige Zuname in Spalte B mehr als ein mal is gesamte B-Spalte vorkommt. Falls dies nicht zutrifft, die Zelle in E einfach blank belassen (BEI LEEREN FEldern, soll diese regel natürlich nicht greifen)

Ich hoffe sehr auf eine gute Lösung von jemandem, grosses DANKESCHÖN schon mal an dieser Stelle!:)

Antwort
von Funfroc, 29

Entweder über die schon genannte zählenwenn-Funktion.

Ich gehe davon aus, dass die Dublikate dann aus der Liste entfernt werden sollen. Dafür gibt es in Excel im Reiter Daten die Funktion Dublikate entfernen als Bordmittel.

Antwort
von pbart, 36

Du könntest dafür die COUNTIF funktion benutzen. Im ersten Parameter muss ein Bereich von Zellen stehen und der Zweite ist dein bestimmtes Suchmuster(Namen). Ich denke wenn du das mit WENN und der UND Funktion verknüpfst sollte das laufen.

Lg

Expertenantwort
von Suboptimierer, Community-Experte für Excel, 31
=WENN(ZÄHLENWENNS(A:A;A2;B:B;B2)>1;"DOPPELT";"")
Kommentar von Hayla88 ,

perfekte lösung, vielen Dank:D

Kommentar von Suboptimierer ,

Bitteschön!

Kommentar von Hayla88 ,

hi. weisst du eventuell auch noch wie ich folgendes tun kann:
ich schreibe z.B. in Zeile nr. 2 Daten über Spalten A bis D.
Und Formatieren die Zeile 2 z.B. durch Hintergrundfarbe Grün.
Jetzt will ich, dass sobald ich in Zeile 3, Spalte A, mit "enter" neue Daten eingebe, dass die gesamte Formatierung von DARÜBER der Zeile (also Zeile 2) automatisch für Zeile 3 übernommen wird, usw.--. DANKE DIR :)

Kommentar von Suboptimierer ,

Formate kannst du mit dem Formatpinsel übernehmen oder mit Kopieren → Inhalte einfügen... → Formate

Sicher kann man das auch irgendwie beim Betätigen der Entertaste auslösen, aber das halte ich für unnötig kompliziert, bzw. ich finde, dass der Aufwand den Ertrag nicht rechtfertigt.

Du kannst ja mal mit bedingter Formatierung spielen. Dann färbst du eine Zeile nur ein, wenn in Spalte A ein Wert <> "" steht.

Expertenantwort
von dkilli, Community-Experte für Computer, 21

Die Frage wurde von Suboptimierer ausgezeichnet beantwortet. Nur ich schlag eine kleine Änderung vor damit angezeigt wird wo die Doppelung(en) stehen. 

=WENN(ZÄHLENWENNS(A:A;A11;B:B;B11)>1;ZEILE();"")

Diese Formel bis zum Ende der Namensliste ziehen. Später kann die Liste ohne weiteres erweitert werden ohne die Formel anzupassen.

Siehe Bild

Keine passende Antwort gefunden?

Fragen Sie die Community