Frage von DieVerlauchung, 33

excel wenn funktion zu einer umfrage?

ich habe eine tabelle mit ungefähr 250 Zeilen, diese kommen von surveymonkey, also von einer Umfrage.

Wenn spalte A ausgefüllt ist und Spalte C und F ausgefüllt ist, soll eine 1 erscheinen. Sonst nichts.

Wenn Spalte A ausgefüllt ist und B und F dann soll eine 3 erscheinen.

Wenn spalte B ausgefüllt ist und Spalte C und F ausgefüllt ist soll eine 2 erscheinen etc

(als beispiel)

wie realisiere ich das, habe total mit der zeit vergessen wie ich das mache ?

Hilfreichste Antwort - ausgezeichnet vom Fragesteller
von Suboptimierer, Community-Experte für Excel, 24

=WENN(UND(A2<>"";C2<>"";F2<>"");1;
WENN(UND(B2<>"";C2<>"";F2<>"");2;
WENN(UND(A2<>"";B2<>"";F2<>"");3;"")))

Ich bin mir sicher, dass das aber auch einfacher geht. Es ist eine logische Umformung von nöten. Ich überlege mir nochmal etwas.

Kommentar von Suboptimierer ,

Reicht das? Ich erkenne kein Muster und kann deswegen nichts vereinfachen.

Expertenantwort
von Oubyi, Community-Experte für Excel, 10

Etwas kompakter als mit WENN lässt sich das mit ANZAHL2 lösen:

=(ANZAHL2(A2;C2;F2)=3)*1+(ANZAHL2(A2;B2;F2)=3)*3+(ANZAHL2(B2;C2;F2)=3)*2

Überschneidungen müssen aber ausgeschlossen sein (also mehr als 3 ausgefüllte Zellen, z.B. A,B,C,F).
Wenn nicht, kann ich das aber auch noch abfangen.
Aber ich suche auch noch nach einer Lösung mit Wahrheitswerten.

Kommentar von Oubyi ,

Wenn vorausgesetzt werden kann, dass NUR diese 3 Kombinationen vorkommen können, dann ist z.B. diese Lösung - ganz ohne Funktion, nur mit Wahrheitswerten möglich:

=((F2<>"")*1)*((A2<>"")*-1+(B2<>"")*4+(C2<>"")*2)+((B2<>"")*(C2<>"")=1)*-4

Wirklich schön ist die aber nicht und übersichtlich schon mal gar nicht.

Kommentar von Oubyi ,

Unter der gleichen Voraussetzung, dass NUR diese 3 Kombinationen vorkommen können, ist das hier etwas übersichtlicher und vlt. etwas schöner:

=((F2<>"")*1)+(((B2<>"")*(C2<>""))*1)+(((A2<>"")*(B2<>""))*2)

P.S.: Das Ganze ist jetzt aber eher "Spielerei". In der Praxis würde ich die Formel mit ANZAHL2 oder WENN nutzen.

Keine passende Antwort gefunden?

Fragen Sie die Community