Frage von Hinbe155, 66

Excel wenn ein Wert größer ist dann?

Hallo, ich habe in exel eine Spalte mit 50 Eingabefeldern. Sobald in eine dieser Spalten, ein Wer größer als 500 ist, dann soll eine 1 angezeigt werden. Wenn kein Wert größer oder gleich 500 ist, dann 0.

Leider ist es mir bisher noch nicht gelungen. Kann mir jemand helfen?

Meine Akutelle nicht funktionierende Lösung:

=WENN(ODER(D6<601;D7<601;D8<601;D9<601;D10<601;D11<601;D12<601;D13<601;D14<601;D15<601;D16<601;D17<601;D18<601;D19<601;D20<601;D21<601;D22<601;D23<601;D24<601;D25<601;D26<601;D27<601;D28<601;D29<601;D30<601;D31<601;D32<601;D33<601;D34<601;D35<601;D36<601;D37<601;D38<601;D39<601;D40<601;D41<601;D42<601;D43<601;D44<601;D45<601;D46<601;D47<601;D48<601;D49<601;D50<601;D51<601;D52<601;D53<601;D54<601;D55<601);"1";"0")

Expertenantwort
von DeeDee07, Community-Experte für Excel, 42

Was denn jetzt? 500 oder 601?

Eine mögliche Lösung wäre

=WENN(MAX(D6:D55)>=500;1;0)

Auf die Anführungszeichen solltest du verzichten, außer du möchtest das Ergebnis explizit als Text formatiert haben.

Antwort
von Member99, 42

Erklärung logischer Operatoren: 

Oder: Das oder ist wahr wenn mindestens eine Anweisung wahr ist. Wenn bei dir nicht alle über 500 sind erhälst du immer denn Dann-Wert

Und: Alle Anweisungen müssen wahr sein

--> Ersetz das oder durch ein Und :)

Antwort
von Orsovai, 66

Wenn egal ist, welcher Wert größer als 500 ist, dann bilde das Maximum und teste dieses.

Kommentar von Hinbe155 ,

Die Summe aus all diesen Werten? Nicht jede Zelle ist immer gefüllt...

Kommentar von Orsovai ,

Nein, nicht die Summe, sondern das Maximum, d.h. das größte aller Elemente mittels Funktion =MAX(...)

Antwort
von Tron1701, 2

Hallo,

wie von "DeeDee07" beschrieben würde ich zudem die Formel verfeinern und eine Zelle (in meinen Beispiel wäre es E1) als einen Bezug für den Wert wählen, der variable ist, denn dann müßte man die Formel nicht Neu schreiben falls sich was ändert.

=WENN(MAX(D6:D55)>=$E$1;1;0)

Gruß Tron

Antwort
von canstyl044, 57

Versuch es mal mit einer verschachtelten Wenn Funktion

Beispiel: =WENN(A184>A183;1;(WENN(A185>A183;1;0)))

Expertenantwort
von Oubyi, Community-Experte für Excel, 25

Werte in A1:A50:

=(MAX(A1:A50)>=500)*1

Antwort
von H3isTheMLG, 36

=WENN(A1>500;1;0)

Dann halt auf alle zellen kopieren

Keine passende Antwort gefunden?

Fragen Sie die Community