Frage von Humi0301, 28

Excel Wenn bedingung hilfe?

Hallo.

Da ich in einer Firma arbeite (Viel mit Excel) und ich mir das arbeiten etwas erleichtern möchte aber nach 2 Stunden Recherche keine Lösung gefunden habe, Frage ich hier.

Ich möchte eine wenn bedingung einfügen wie folgt:

Wenn eine andere Zelle das Wort Alu enthält soll in der Ausgewählten Zelle 2,7 erscheinen. Wenn die Zelle das Wort V2A enthält dann soll dort 7,7 erscheinen.

Die Zelle zum auswählen habe ich schon mit einer Drop-Down Tabelle bestückt,

Ich freue mich über jegliche Hilfe!

Mfg Humair

Expertenantwort
von Suboptimierer, Community-Experte für Excel, 23

Was meinst du mit "enthält". Steht da genau "Alu" drin oder kann da auch "Stahl Alu Plastik" drin stehen und du suchst den Text innerhalb der Zelle.

Ersteres ist einfach: =WENN(A1="Alu";2,7;WENN(A1="V2A";7,7;0))

Suchst du innerhalb des Texts, kannst du FINDEN verwenden.

=WENNFEHLER((FINDEN("Alu";A1)>0)*2,7;WENNFEHLER((FINDEN("V2A";A1)>0)*7,7;0))

(ungetestet)

Kommentar von Humi0301 ,

Danke für die Antwort, Copy&Paste, Zellen ändern, klappt!
Mein Chef hat sich gefreut!

Kommentar von Suboptimierer ,

Bitteschön!

Antwort
von Y0DA1, 21

ist doch ganz einfach:

=wenn(A1="Alu";2,7;wenn(A1="V2A";7,7;"")

"" ist dann einfach nichts oder leer. Du kannst auch was anderes dafür ein setzen. Du kannst auch weitere wenn Bedingungen einsetzen ;)

Kommentar von Humi0301 ,

Danke so hatte ich es vorher versucht aber da wir mit so vielen Werten arbeiten, eher suboptimal :(

Kommentar von Y0DA1 ,

achso, ihr hab ganz viele. Na dann hab ich einen viel besseren Vorschlag, als die bisherigen Antworten die du hier bekommen hast:

Du erstellst in der Excel-Datei in einer zweiten Tabelle eine Auflistung aller Werte, so:

       A        B       C   
1   Alu      2,7
2  V2A     7,7
3    X       8,2
4    y       9,9
usw.

in der ersten Tabelle hast du z.B. in Zeile D8 dann Alu eingegeben und in Zeile E8 soll nun automatisch 2,7 erscheinen. Das kannst du mit der Formel: 

=SUMMEWENN(Tabelle2.A1:Tabelle2.A11;D8;Tabelle2.B1:Tabelle2.B11)

machen. Die ist so aufgebaut:

=SUMMEWENN(Anfang:Ende_der_Wörter;Gesuchtes_Wort;Anfang:Ende_der_Werte)

Am aktuellen Rechner hab ich jetzt leider nur OpenOffice drauf,daher kann ich aktuell nicht testen, ob die Formel in Excel diegleichen Parameter an den stellen wie in OpenOffice hat (sollten aber so sein).

So kannst du sogar hunderte verschiedene Werte erfragen, mit einer ganz kleinen Formel und wenn die Werte sich mal ändern, diese auch ganz leicht abändern ;)

Keine passende Antwort gefunden?

Fragen Sie die Community

Weitere Fragen mit Antworten