Frage von Blokkmonsta25, 100

EXCEL WENN- Funktion mit Formel und mehreren Bediengungen?

Hallo erstemal,

ich habe eine Exceltabelle wo ich das Gehalt eines Unternehmer eintragen kann. Dabei möchte ich die Formel vom Einkommensteuerrechner für Selbststädnige einbinden.

Ich will jetzt eigentlich nur das der Unternehmer sein Jahresgehalt eintragen, und dabei im dann angezeigt wird wieviel Steuern dieser zahlen muss.

  • bis 8.652 Euro: ESt = 0
  • von 8.653 Euro bis 13.669 Euro: ESt = (993,62 * y + 1.400) * y | y = (zvE - 8.652) / 10.000
  • von 13.670 Euro bis 53.665 Euro: ESt = (225,4 * z + 2.397) * z + 952,48 | z = (zvE - 13.669) / 10.000
  • von 53.666 Euro bis 254.446 Euro: ESt = 0,42 * zvE - 8.394,14
  • ab 254.447 Euro: ESt = 0,45 * zvE - 16.027,52

+Est = Steuern

+zvE = zuversteuerndes Einkommen

Ich komme mit der Wenn- Funktion bei dieser Thematik überhaupt nicht klar. Wo ich mir sicher bin, ist das diese sehr sehr lang vermutlich sein wird.

Würde mich freuen wenn mir jemand weiterhelfen kann.

Danke

Hilfreichste Antwort - ausgezeichnet vom Fragesteller
von dkilli, 52

Als Spaltenüberschriften steht in Spalte A1 zvE und in B1 Lohnsteuer. In C1 Prozentsatz

In A3 steht das zu versteuernde Einkommen und in B3 die zugehörige Lohnsteuer mit dem Prozentsatz.

In B3 ist folgende Formel eingetragen

=WENN(A3<=8652;0;WENN(A3<=13669;(993,62*(A3-8652)/10000+1400)*(A3-8652)/10000;WENN(A3<=53665;(225,4*(A3-13669)/10000+2397)*(A3-13669)/10000+952,48;WENN(A3<=254446;0,42*A3-8394,14;WENN(A3>254446;0,45*A3-16027,52;"")))))

Es können Rundungsfehler von 1€ auftreten, da ich nicht weiß mit wie viel Stellen das Finanzamt rechnet.

Kontrollieren kannst du bei www.bmf-steuerrechner.de

In C3 =B3/A3*100

Diese Formeln mit den zvE kannst du herunter ziehen

Siehe das Bild wie viel die Prozent von der Lohnsteuer die sogenannten Geringverdiener bezahlen müssen. Obwohl jede Regierung die Steuern gesenkt hat!!!???

Ich ich habe für die Formel sehr lange gebraucht um sie hinbekommen.

http://www.bilder-upload.eu/show.php?file=35617e-1461068980.png



Expertenantwort
von Suboptimierer, Community-Experte für Excel, 66

Für die Variablen würde ich mir Namen im Namensmanager anlegen. 

Name: zvE, Formel: =$A$1
Name: y, Formel: =zvE-8652/10000

Am besten die Grenzen (8652) sogar auch noch benamsen oder zumindest in einer Liste festhalten und auf die Zellen referenzieren.

Dann bildest du für alle 5 Fälle eine Formel und gibst vorne die Untergrenze an (benamter Bereich "Grenzen"):

0    0
8653 <Formel ESt1>
...

Auf diesen Bereich greifst du mit dem SVERWEIS zu:

=SVERWEIS(zvE;Grenzen;2)
Kommentar von Blokkmonsta25 ,

Werde ich dann mal ausprobieren, klingt aber schonmal logisch. Danke dir. =)

Antwort
von dkilli, 15

Es immer wieder schade, dass der, die Fragesteller(in) noch nicht mal die Zeit oder Lust haben die Antworten zu bewerten. Auch diese Frage zu  beantworten  hat sehr lange gedauert. Sehr viele Leser von GF geben sich sehr viel Mühe die Fragen zu beantworten. 

Man kann nur sagen

SCHADE, SCHADE, 

SCHADE, SCHADE, 

SCHADE, SCHADE, 

Kommentar von Blokkmonsta25 ,

Bevor ich so wie du und die anderen ewig drauf warte ob jemand antwortet oder nicht, hätte ich es einfach mal getestet

Oben sind 3 Antworten. Jede der 3 Antworten ist richtig. Mit allen ist es lösbar nur auf verschiedenen Wegen!

Im Qualitätsmanagmentbereich sagt man, keine Reklamation ist ein gutes Feedback! 

Schlussfolgerung: 

Wenn man etwas nicht reklamiert, ist man mit der Antwort vorran gekommen. Ansonsten würde man sich ja wieder melden!

Kommentar von dkilli ,

Erst mal Danke für den Stern. 

Ob man das von dem Qualitätsmanagmentbereich ohne weiteres auf Gute Frage übernehmen kann??? 

Ich und andere von GF sind uns einig, dass je länger die Beantwortung dauert, so weniger kommt eine Rückmeldung.

Jetzt noch einen schönen Tag. 

Antwort
von Garfield0001, 58

ich habe vorhin bei vbarchiv.de ein Makro dazu hoch geladen.
da muss man am ende nur noch eingeben :

=EST_BERECHNUNG(zvE, LEL, Jahr, Ta)

zvE ist das "zu versteuernde Einkommen"
LEL sind evtl Lohnersatzleistungen (oder "0")
Jahr ... ist klar
Ta ist die Tabelle (Single = 1, verheiratet = 2) (mal grob gesagt)

de Tipp wird leider noch nicht angezeigt (wird noch geprüft).
ansonsten unter "Tobias König" zu finden (bereits 2 Tipps existieren)

Kommentar von Garfield0001 ,

Keine passende Antwort gefunden?

Fragen Sie die Community

Weitere Fragen mit Antworten