Frage von steve56, 19

Excel VBA Wenn Formel einfügen?

Hallo

Ich habe jetzt z.b. in der Zelle A2 einen veränderlichen Wert stehen beispiel: Wenn A2=292 Then B2=Janina Wenn A2=999 Then B2=Stefan kann mir jmd weiterhelfen?

Expertenantwort
von Oubyi, Community-Experte für Excel, 18

Was hat das mit VBA zu tun?
Formel in B2:
=WENN(A2=292;"Janina";WENN(A2=999;"Stefan";"???"))
oder VBA, wenn es sein muss:
Range("B2").FormulaLocal = "=WENN(A2=292;""Janina"";wenn(A2=999;""Stefan"";""???""))"

Ohne Formel in B2:

Select Case (Range("A2").Value)
Case "292": Range("B2").Value = "Janina"
Case "999": Range("B2").Value = "Stefan"
Case Else: Range("B2").Value = "???"
End Select


Kommentar von steve56 ,

Da ich mich in VBA reinsteigern will fange ich gerade klein an und somit hätte ich einen Anhaltspunkt zum testen aber danke :)

Kommentar von agent888 ,

Wenn du gerade damit beginnst sind diese Tutorials vllt ganz nützlich: http://www.youtube.com/playlistlist=PLwZPoJGFBME_jc3lQ1sphhPDQycsvJusw

Keine passende Antwort gefunden?

Fragen Sie die Community

Weitere Fragen mit Antworten