Excel Tabellenprofi?

... komplette Frage anzeigen

3 Antworten

Erstmal der erste Teil:
Formel in E3:
=(C3>2100)+(D3>2100)
Jetzt steht ja in E3 entweder 0, 1 oder 2.
Habe ich Dich richtig verstanden?

Was meinst Du genau mit:


Der Wert der bereits drin steht (manuell reingeschrieben) soll zusätzlich, außerhalb der Formel, addiert werden

Heißt das, in E3 soll ein Wert manuell eingetragen sein?
Das geht nicht! In einer Zelle kann nur eine Formel ODER ein Wert stehen.
Und was heißt "außerhalb der Formel"?

Für die Färbung:
Markiere C3:E3 und gehe auf:
Bedingte Formatierung/ Neue Regel/ Formel zur Ermittlung der zu formatierenden Zellen verwenden/ Werte formatieren, für die diese Formel wahr ist -->:
=$E3=1
Formatieren/ OK.
Das gleiche nochmal mit:
=$E3=2

Das Erkennen der Hintergrundfarbe wohl möglich, aber komplizierter und eher nicht zu empfehlen. Hast Du da vlt. eine andere Möglichkeit?

P.S.:
Dass Du den Text Deiner Frage jetzt nochmal völlig neu geschrieben hast, gefällt mir nicht besonders. Warum nicht gleich so?

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von Roundin
05.07.2016, 16:07

Hallo,

deine Formel kommt mir sehr unbekannt vor aber wirkt, nur exakt falsch rum. Wenn die Werte in zweifach überschritten werden wird eine '2' ausgegeben. Wenn die Werte zweifach unterschritten wird eine '0' ausgegeben. 

Dann würde ich gerne noch den Wert einer anderen Spalte 'F3' zu der ausgegebenen '0', '1' oder '2' addieren. Die Färbung kontrolliere ich gleich noch.

Vielen Dank für deine Mühe!

0

Für dein erstes Anliegen musst du in Zelle E3 folgende Funktion eingeben:

=WENN(XODER(C3<2100; D3<2100); "1"; WENN(UND(C3<2100; D3<2100); "2"; "0"))

Es wird die Anzahl der Zellen unter 2100 ausgegeben.

Um die Hintergrundfarben zu ändern, musst du bei den benutzerdefinierten Symbolen die Hintergrundfarbe auswählen und sie wertspezifisch ändern. Du findest sie (ab 2007) im Register Start rechts.

Um die Hintergrundfarbe einer Zelle zu erkennen, müsstest du ein Makro (in Visual Basic) schreiben. ^^

Ich hoffe, ich konnte dir helfen; wenn du noch Fragen hast, kommentiere einfach. 

LG Willibergi 

PS: Du kannst in eine Zelle, in der eine Formel steht, nichts manuell einschreiben!

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von Roundin
05.07.2016, 15:54

Hallo,

Deine Formel funktioniert mit einem Punkt wenn der Wert einmalig unterschritten wird. Bei zweimaligem Unterschreiten allerdings wird nur eine '1' statt einer '2' ausgegeben.

Mein Anliegen habe ich überarbeitet. Es sollte nun deutlicher sein was ich meine. Vielen Dank für deine Mühe!

0

1) =ZÄHLENWENN(C3:D3;"<2100")
"Der Wert der bereits drin steht..." → verstehe ich nicht.

2) bedingte Formatierung

3) Schwer umzusetzen (Namensmanager → ZELLE.ZUORDNEN)
Besser: Regel finden, wann die Zellen blau sind und das Ergebnis kombinieren mit WENN(ODER(C3<2100;<Formel C3 blau>);1;0)+WENN(D3... Hierbei würdest du auf ZÄHLENWENN verzichten.

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von Roundin
05.07.2016, 15:54

Hallo,

Mein Anliegen habe ich überarbeitet. Es sollte nun deutlicher sein was ich meine. Vielen Dank für deine Mühe!

0