Frage von deschroe, 64

Excel Tabellenblätter vergleichen, nur wie?

Hallo Liebe Gemeinde, Gerne würde ich bei einer Excel Datei die verschiedenen Datenblätter miteinander vergleichen. Dabei soll der Januar mit dem Februar verglichen werden und der Februar mit dem März. Monatlich kommen neue Kundenprojekte hinzu und bereits bestehende Projekte haben einen neuen Status erhalten. Dabei soll wie im Anhang ein Überblick gegeben werden. Ich möchte ungern für jeden einzelnen Kunden die Daten aus den entsprechenden Datenblätter manuell raussuchen. Vielleicht hat ja jemand einen Rat für mich.

Ich selbst würde es mit der Funktion SVerweis probieren:

Allerdings habe ich einen Fehler in meiner Formel.

=SVERWEIS(Tabelle7[[#Diese Zeile];[Verkaufspotentiale Bezogen auf]];Tabelle1[[Verkaufspotentiale Bezogen auf]:[Verkaufspotentiale zuständig ]];3;FALSCH)

Grüße Dennis

Hilfreichste Antwort - ausgezeichnet vom Fragesteller
von Ninombre, Community-Experte für Excel, 60

Ohne die Datei zu kennen, ist es schwer den Fehler zu finden. Sind die Daten als Tabelle formatiert, wenn Du [] angibst?

Irgendwie sieht die Matrix für die Suche nicht passend aus. In deinem Beispiel wären das nur zwei Spalten, da kann der Wert 3 (aus der 3. Spalte des definierten Bereichs übernehmen) nicht passen.
Du bewegst Dich doch, wenn ich es richtig verstanden habe, innerhalb einer Datei. Wenn anhand des Wertes von Spalte A der Wert in B übernommen werden soll:
=WENNFEHLER(SVERWEIS($A2;Januar!A:B;2;FALSCH);"")
In meinem Beispiel wäre das Tabellenblatt für Januar auch so bezeichnet.
Das WennFehler fängt die #NV ab, wenn es das Projekt in diesem Monat nicht geben sollte.

Kommentar von deschroe ,

Hallo,

vielen Dank für die Hilfe und den Tipp. Ich habe die einzelnen Felder nochmal kontrolliert und den Fehler dank dir gefunden. Funktioniert so wie ich es mir vorgestellt habe.

Danke sehr

Antwort
von PWolff, 57

Für ein solches Szenario sieht Excel sogenannte Pivot-Tabellen vor. Wie man die erstellt und einrichtet, findest du in der Excel-Hilfe.

Es ist allerdings alles andere als einfach, sich in dieses Thema hineinzuarbeiten, aber ich würde es unbedingt empfehlen, wenn du öfters mit derartigen Problemstellungen zu tun hast.

Ansonsten könntest du für den Anfang mit den Tabellenblatt-Funktionen SUMMEWENN und/oder SUMMEWENNS arbeiten; diese sind wesentlich leichter zu verstehen, aber natürlich bei weitem nicht so leistungsfähig.

Kommentar von deschroe ,

Vielen Dank für die schnelle Antwort. Ich habe bereits mit Pivot Tabellen gearbeitet und ich denke, dass ist nicht die Lösung des Problems. Ich würde im Prinzip gerne aus dem Datenblatt "Januar" in meiner Übersicht in der Spalte "Januar" den entsprechenden Projektstatus eintragen. Ebenso soll dies in den Folgemonaten ablaufen. Auf Grund der hohen Datenmenge wäre es schön, wenn ich eine Formel hätte die mir in meiner Übersicht den entsprechenden Wert aus den Datenblättern einträgt.

Antwort
von deschroe, 42

Hier mal ein Bereich der Tabelle als Screenshot

Keine passende Antwort gefunden?

Fragen Sie die Community

Weitere Fragen mit Antworten